Graylog Could not retrieve Elasticsearch cluster health

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!

1. Describe your incident:
I restored the server (standalone) from a VMWare snapshot. I am now getting “Graylog Could not retrieve Elasticsearch cluster health.” on the overview page as well as “There is no index target to point to. Creating one now.” for my node. My current indices appear to be working but when I create a new one and point a stream at it I get

While retrieving data for this widget, the following error(s) occurred:

    Elasticsearch exception [type=index_not_found_exception, reason=no such index []].

When I

curl -X GET "localhost:9200/_cluster/health?pretty"

I get

  "cluster_name" : "graylog",
  "status" : "green",
  "timed_out" : false,
  "number_of_nodes" : 1,
  "number_of_data_nodes" : 1,
  "active_primary_shards" : 1000,
  "active_shards" : 1000,
  "relocating_shards" : 0,
  "initializing_shards" : 0,
  "unassigned_shards" : 0,
  "delayed_unassigned_shards" : 0,
  "number_of_pending_tasks" : 0,
  "number_of_in_flight_fetch" : 0,
  "task_max_waiting_in_queue_millis" : 0,
  "active_shards_percent_as_number" : 100.0

2. Describe your environment:

  • OS Information:
    Rocky Linux 8 (8 CPU/16GB) on VMWare ESXi 7
    OS on 200GB; Data on 2TB

  • Package Version:
    Graylog 4.3.3+86369d3
    MongoDB v4.2.21
    Elasticsearch 7.10.2

  • Service logs, configurations, and environment variables:

3. What steps have you already taken to try and solve the problem?
I have rebooted the server

4. How can the community help?
I am new to Graylog (2 months) and any help would be greatly appreciated!

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

I have solved my own problem.

Apparently, I ran out of shards. I removed many of the old default indices to free up shards, and all was right with the world again.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.