Graylog Connection Refused After VM Reboot

I had a working Graylog instance working on an Ubuntu 18.04 install. After turning off my FreeNAS machine to add new drives and create a new, separate pool, Graylog no longer launches. I get a refused to connect message.

I’ve also reverted to several prior snapshots with no difference.

Java, Mongo, ElasticSearch, Graylog, and Graylog Sidecar all show Running when I do a status command.

Journal displays:

Oct 02 20:24:00 graylog systemd[1]: graylog-server.service: Main process exited, code=exited, status=1/FAILURE
Oct 02 20:24:00 graylog systemd[1]: graylog-server.service: Failed with result 'exit-code'.
Oct 02 20:24:01 graylog filebeat[961]: 2020-10-02T20:24:01.318-0500        INFO        [monitoring]        log/log.go:145        Non-zero metrics in the last 30s        {"monitoring": {"metrics": {"beat":{"cpu":
Oct 02 20:24:07 graylog graylog-sidecar[1108]: time="2020-10-02T20:24:07-05:00" level=error msg="[UpdateRegistration] Failed to report collector status to server: Put http://192.168.1.25:9000/api/sidecars/2ee812
Oct 02 20:24:11 graylog systemd[1]: graylog-server.service: Service hold-off time over, scheduling restart.
Oct 02 20:24:11 graylog systemd[1]: graylog-server.service: Scheduled restart job, restart counter is at 67.
-- Subject: Automatic restarting of a unit has been scheduled
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support

And syslog displays:

Oct 2 20:24:37 graylog graylog-sidecar[1108]: time="2020-10-02T20:24:37-05:00" level=error msg="[UpdateRegistration] Failed to report collector status to server: Put http://192.168.1.25:9000/api/sidecars/2ee81295-e283-45ba-9471-09d9c0b0c74e: dial tcp 192.168.1.25:9000: connect: connection refused

No firewall rules (this is a local network)
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Sidecar yaml has the correct IP:
# The URL to the Graylog server API.
server_url: “http://192.168.1.25:9000/api/

So I’ve just reached a point where I need to ask for help.

All my previous searches led to misconfigured IPs and firewalls, but I think I’ve covered that. Any ideas?

Solved it!

It was the stupidest thing, but I hope it helps someone. I had incorrectly added “CST” for a timezone update, when I should have added America/Chicago.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.