Graylog API Token Setting

I have updated my graylog servers to 4.0, I noticed the graylog sidecar tokens have changed causing the sidecars to not report I am trying to find a way to change the token back using the curl commands instead of changing each individual instance. Has anyone found these commands or know of a way to change the token.


Hello, Maybe I can help you.
Would this be simlular to your problem?

I do see the tokens there but the actual token values have changed, I am trying to find a way to set the token value so that I do not have to reset sidecars. If I were to change the sidecars it would be over 500 values I would have to change. I feel as though I could set the token value on the vm itself and I would not have to waste my time changing the values


I understand now, and yeah that would be a pain.
Honestly, I haven’t used GL sidecar we have always used Nxlog, or Rsyslog to ship logs. What I tried to do for you was a quick search to see if I could find something for you that could possibly help, but in this case looks like you need someone more knowledgeable. What I can try to do is test this in my lab and see if I run into the same problem. I need to know is a little more about your environment like version/s and configuration. This would also help anyone passing by to help you.

The system I work on has strict requirements to not post or say anything about logs and configs it sucks when these issues arise, But I was able to figure out the issue and sidecars are now reporting.


That is understandable for a a comapany to do that.
Glad you have it fixed. Can I ask how you were able to fix it? This would help anyone passing by the forum.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.