Graylog 3.3 typing problem in search fields

Hello to everyone!
After updating Graylog from 3.2 to 3.3 I have encountered the following problem in all the search query fields. For example:
If I type “a” in the search field, the query string has value “a”.
If then I type “b” in the search field, the query string has value “aab”
If then I type “c” in the search field, the query string has value “aababc”
and so on.
I was sure that this is a browser problem but I tried different browsers (Safari, Firefox, Chrome, Edge) in different OS but the problem still remains.
With 3.2 no problems.

Can you help me?

he @m.toso

did you have any plugins installed in Graylog?

The installed plugins are Threat Intelligence Lookup, AWS and Geo-Location Processor.

This is the content of the search field after typing “abcdef”

Do you have the plugins on the same version as the current graylog version?

I am having the same issue:

graylog@graylog-1:~$ cd /usr/share/graylog/plugin/
graylog@graylog-1:~/plugin$ ls -ltr
total 33096
-rw-rw-r--. 1 graylog graylog  6318257 May 20 13:47 graylog-plugin-collector-3.3.0.jar
-rw-rw-r--. 1 graylog graylog 19710562 May 20 13:48 graylog-plugin-aws-3.3.0.jar
-rw-rw-r--. 1 graylog graylog  7852513 May 20 13:49 graylog-plugin-threatintel-3.3.0.jar

I am running graylog on k8s through the helm chart.

Then perhaps try to clean the browser caches. We saw that problem in the past and it comes with multiple versions of a javascript library we ship. \

- Konrad

Hi Konrad! It was a plugin problem!
I forgot to mention the graylog-plugin-telegram-notification. I removed it and everything worked.
Now I updated it to the latest version and everything works fine! Thank you!

1 Like

I had upgraded it but it didn’t work until I cleaned browser cached.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.