[Graylog 3.3.0 docker] Unable to load credentials when creating AWS Kinesis/CloudWatch input

Hi,

This error always shows up when I am trying to create AWS Kinesis/CloudWatch input with either “Automatic” and “Key or Secret” AWS Authentication Type:

Unable to load credentials from any of the providers in the chain AwsCredentialsProviderChain(credentialsProviders=[SystemPropertyCredentialsProvider(), EnvironmentVariableCredentialsProvider(), WebIdentityTokenCredentialsProvider(), ProfileCredentialsProvider(), ContainerCredentialsProvider(), InstanceProfileCredentialsProvider()]) : [SystemPropertyCredentialsProvider(): Unable to load credentials from system settings. Access key must be specified either via environment variable (AWS_ACCESS_KEY_ID) or system property (aws.accessKeyId)., EnvironmentVariableCredentialsProvider(): Unable to load credentials from system settings. Access key must be specified either via environment variable (AWS_ACCESS_KEY_ID) or system property (aws.accessKeyId)., WebIdentityTokenCredentialsProvider(): Either the environment variable AWS_WEB_IDENTITY_TOKEN_FILE or the javaproperty aws.webIdentityTokenFile must be set., ProfileCredentialsProvider(): Profile file contained no credentials for profile ‘default’: ProfileFile(profiles=), ContainerCredentialsProvider(): Cannot fetch credentials from container - neither AWS_CONTAINER_CREDENTIALS_FULL_URI or AWS_CONTAINER_CREDENTIALS_RELATIVE_URI environment variables are set., InstanceProfileCredentialsProvider(): Unable to parse Json String.]

What I have tried so far:

  1. Set up the credentials on AWS Plugin Configuration
  2. Set up the credentials in the environment variables:
  • GRAYLOG_AWS_ACCESS_KEY_ID=AKXXXXXXXXXXXXXXXXXX
  • GRAYLOG_AWS_SECRET_ACCESS_KEY=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

On which part am I doing it wrong?

Thanks.

Set the credentials in graylog’s environment section on the docker-compose file without “GRAYLOG_” prefix like so:

  • AWS_ACCESS_KEY_ID=AKXXXXXXXXXXXXXXXXXX
  • AWS_SECRET_ACCESS_KEY=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

and use AWS Authentication Type “Automatic”.

1 Like