Graylog 3.1 with nginx https - api browser not work


I have graylog servier in version 3.1.
i used nginx to make the browser secure with https.
everything work well, but when i go to the api browser i get nothing :frowning:

this my nginx conf :
listen 443 ssl http2;
ssl on;
ssl_certificate /etc/letsencrypt/live/;
ssl_certificate_key /etc/letsencrypt/live/;
ssl_session_timeout 5m;
ssl_protocols TLSv1.2;
ssl_prefer_server_ciphers on;
access_log /var/log/nginx/graylog.access.log;
error_log /var/log/nginx/graylog.error.log;
location / {
proxy_set_header Host $http_host;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Graylog-Server-URL https://$server_name;

this the config of the graylog :
http_bind_address =

in the browser the link of the api get me to… , i also tried to change the begin to my site/api… , but get white page.

i tried everything, including every guide i saw in the internet.

someone can help me? thanks!

You may want to try setting the http_external_uri option within the graylog server.conf file.

Hi. when i configure this setting, after i restarting the graylog-server service, anything didn’t work.
maybe i need chage more things?

what i need to write there?

i write this : http_external_uri =

take your first configuration and type in manually

for which line? i need to configured that?

that should be the direct input to your browsers URL bar.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.