Graylog 2.2 and Elasticsearch 2.4.4


(linux.gokan) #1

Hello

Graylog constantly gives the following warning.
What would be the reason ?

error:

	at java.lang.Thread.run(Thread.java:745) [?:1.8.0_121]
2017-03-06T13:35:39.197+03:00 INFO  [IndexerClusterCheckerThread] Indexer not fully initialized yet. Skipping periodic cluster check.
2017-03-06T13:35:39.705+03:00 WARN  [V20161130141500_DefaultStreamRecalcIndexRanges] Interrupted or timed out 

2017-03-06T13:34:52.609+03:00 ERROR [AnyExceptionClassMapper] Unhandled exception in REST resource
org.elasticsearch.discovery.MasterNotDiscoveredException: null

Sockets:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:27017         0.0.0.0:*               LISTEN      1248/mongod     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1159/sshd       
tcp6       0      0 192.168.1.24:9000       :::*                    LISTEN      2092/java       
tcp6       0      0 192.168.1.24:9200       :::*                    LISTEN      1935/java       
tcp6       0      0 192.168.1.24:9300       :::*                    LISTEN      1935/java       
tcp6       0      0 :::22                   :::*                    LISTEN      1159/sshd       
tcp6       0      0 127.0.0.1:9350          :::*                    LISTEN      2092/java       
tcp6       0      0 ::1:9350                :::*                    LISTEN      2092/java       
udp6       0      0 192.168.1.24:5142       :::*                                2092/java       

Elasticsearch.yml:

cluster.name: graylog
network.host: 192.168.1.24
discovery.zen.ping.multicast.enabled: false
script.inline: false
script.indexed: false
script.file: false
# curl -XGET 'http://192.168.x.x:9200/_cluster/health?pretty=true'
  "cluster_name" : "graylog",
  "status" : "green",
  "timed_out" : false,
  "number_of_nodes" : 1,
  "number_of_data_nodes" : 1,
  "active_primary_shards" : 1,
  "active_shards" : 1,
  "relocating_shards" : 0,
  "initializing_shards" : 0,
  "unassigned_shards" : 0,
  "delayed_unassigned_shards" : 0,
  "number_of_pending_tasks" : 0,
  "number_of_in_flight_fetch" : 0,
  "task_max_waiting_in_queue_millis" : 0,
  "active_shards_percent_as_number" : 100.0
}

Thanks.


(Jan Doberstein) #2

hej @linux.gokan

your ES Cluster shows green and has a master available - did you check if GL is able to connect to this master and can reach ES from what is configured?

regards
Jan


(linux.gokan) #3

Now working… Thank you so much.