Fail to import Content Packs from ver Graylog 2.4.3 to Graylog 4.2.1

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!
Content Packs

1. Describe your incident:
Try to install Content Packs from Graylog 2.4.3 to Graylog 4.2.1 get error :Unsupported content pack version 0. could not install content pack

2. Describe your environment:

  • OS Information:

  • Package Version:

  • Service logs, configurations, and environment variables:

3. What steps have you already taken to try and solve the problem?

4. How can the community help?

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

Hello && Welcome

If this is not a default content pack then it would mean what ever content pack you have installed on GL version 2.4.3 no longer works for the newer version of Graylog.

If this is a default content pack you have to remove it and update/install your content pack.

To help you further please take a look here

My goal was to transfer in easy way configuration from old version gl 2.4.3 to new system I’m creating 4.2.1.
Configuration is: inputs ,screams ,dashboards’.
There is any solution for this activity ?


I’m actual in the process of upgrading multiply GL servers 2.4 to 4.2 versions. I have a choice either an in place upgrade which consist of following the upgrade paths with MongoDb, Graylog, and elasticsearch or create a new Graylog server and copy the configuration over.

EDIT: Here is some more insights for you. Remind you Elasticsearch has to be upgrade to the latest minor version before installing a major version. Also look at MongoDb documents for how to upgrade. this does require an update path. Graylog has stipulations on what version of elasticsearch it can use and the same with MongoDb. Best idea would be to upgrade Graylog 3.0, find out what version of elasticsearch is need then upgrade that. Last would be MongoDb. Keep it simple. I haven’t had any issues with using an older version on mongo during my upgrade process. Just making sure you don’t install the latest version of Elasticsearch. Then you might be in trouble when down grading elasticsearch to accommodate Graylog version 4.2. What I decided to do was create a new Graylog server and configure it to resemble the older version of Graylog. Take note there were a few different changes between all these versions and it is highly possible that issues will occur during your upgrade process.

Hope that helps

Hello. Well, I had the same goal and ended up going with the other solution. I needed to upgrade from 2.3, so I installed a new one, and try to transfer only the dashboards, but without success.

Using content packs, the structure is very different, and ended up with an error. And even using a solution I found in forums, about using API. I found out that 4.2 and 2.3 are very different. I couldn’t find the option to create widgets through API in version 4.2.

Honestly imo, the API documentation lacks a lot of information.

I am now in the painful process of recreating everything…

I had to do the same, it happens when things change after 2 major versions. Just a side note, if you need to know what has changed you can look here.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.