Extend disk size


(Kbakenov) #1

hi! all
please see extend disk size,

step by step
https://github.com/Graylog2/documentation/issues/287


(Jochen) #2

Hi @kbakenov,

it would help if you paid attention to the commands you’re executing and their output.

For example this is pretty obviously a copy & paste error:

ubuntu@graylog:~$ sudo parted -a optimal -- /dev/sdb unit \\
parted: invalid token: \

In this case, the double backslash (\\) is simply a hint that the command continues on the next line.


(Kbakenov) #3

Hi, ok,
insert 2 line command - in one line without “\”?
Or
2line command insert. ??
How correct?
If not need “\” delete this in manual. And add remark insert this 1 or 2 lines…
I’m not user ubuntu cli…i understand operand(symbol)\.
This normaly, i use copy/paste command

I use ctl script for setting ntp, admin pass…

Can creat this operational with graylog ctl ?! In auto mode. Steps. After shutdown. Then add disk. Then use ctl(use all avilable space, ). Rebot. Extend disk overall - one command.


(Jochen) #4

We’ve reworked the section about extending disk space in the virtual machine appliance: http://docs.graylog.org/en/2.2/pages/configuration/graylog_ctl.html#extend-disk-space

Give it a try.


(Kbakenov) #5

HI Jochen, i try! thank!

can add in Manual
in section Add static ip/DNS settings
paste in format

dns-namesrvers 8.8.8.8


(Jochen) #6

I don’t know what you mean. Please elaborate.


(Kbakenov) #7

Hi Jochen!
1)DNS resolve settings in manual - i not find - in site graylog,
i find from ubuntu site.
problem with …“nameservers”…"dns-nameservers"
change resolf.conf or change other file. after restart not save config…
or insert after static ip address in etc/network/interfaces…

2)small error in step:

ubuntu@graylog:~ sudo diff -qr --suppress-common-lines var/opt/graylog/data /mnt/tmp diff: var/opt/graylog/data: No such file or directory ubuntu@graylog:~ sudo diff -qr --suppress-common-lines var/opt/graylog/data /mnt/tmp
diff: var/opt/graylog/data: No such file or directory
ubuntu@graylog:~$ sudo su
root@graylog:/home/ubuntu# cd /var/opt/graylog/data
root@graylog:/var/opt/graylog/data# ls
elasticsearch etcd journal mongodb
root@graylog:/var/opt/graylog/data# sudo diff -qr --suppress-common-lines /var/opt/graylog/data /mnt/tmp
Only in /mnt/tmp: lost+found
root@graylog:/var/opt/graylog/data#

var/log/… …begin from /var


(Jochen) #8

You’ll have to add the respective directive to the /etc/network/interfaces file.

Thanks, I’ve fixed that.