ERROR [Version] Unable to read version.properties, this build has no version number


(oarmand) #1

Hi i have a problem after use graylog-server-2.3.1-1.noarch.rpm on redhat 7.3.
when i start the server, it’s run but in logs i can see an error :

2017-09-13T16:18:07.110+02:00 ERROR [Version] Unable to read version.properties, this build has no version number.
java.lang.IllegalArgumentException: Input string is NULL or empty
        at com.github.zafarkhaja.semver.VersionParser.<init>(VersionParser.java:162) ~[graylog.jar:?]
        at com.github.zafarkhaja.semver.VersionParser.parseValidSemVer(VersionParser.java:194) ~[graylog.jar:?]
        at com.github.zafarkhaja.semver.Version.valueOf(Version.java:265) ~[graylog.jar:?]
        at org.graylog2.plugin.Version.fromClasspathProperties(Version.java:219) [graylog.jar:?]
        at org.graylog2.plugin.Version.fromClasspathProperties(Version.java:199) [graylog.jar:?]
        at org.graylog2.plugin.Version.fromClasspathProperties(Version.java:173) [graylog.jar:?]
        at org.graylog2.plugin.Version.<clinit>(Version.java:66) [graylog.jar:?]
        at org.graylog2.bootstrap.CmdLineTool.<clinit>(CmdLineTool.java:90) [graylog.jar:?]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:88) ~[?:1.8.0]
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:57) ~[?:1.8.0]
        at java.lang.reflect.Constructor.newInstance(Constructor.java:437) [?:1.8.0]
        at com.github.rvesse.airline.parser.ParserUtil.createInstance(ParserUtil.java:39) [graylog.jar:?]
        at com.github.rvesse.airline.DefaultCommandFactory.createInstance(DefaultCommandFactory.java:25) [graylog.jar:?]
        at com.github.rvesse.airline.parser.ParserUtil.createInstance(ParserUtil.java:94) [graylog.jar:?]
        at com.github.rvesse.airline.parser.ParseResult.getCommand(ParseResult.java:114) [graylog.jar:?]
        at com.github.rvesse.airline.parser.command.CliParser.parse(CliParser.java:54) [graylog.jar:?]
        at com.github.rvesse.airline.Cli.parse(Cli.java:107) [graylog.jar:?]
        at com.github.rvesse.airline.Cli.parse(Cli.java:93) [graylog.jar:?]
        at org.graylog2.bootstrap.Main.main(Main.java:43) [graylog.jar:?]
2017-09-13T16:18:07.309+02:00 ERROR [CmdLineTool] Plugin "Elastic Beats Input" requires version 2.3.1 - not loading!
2017-09-13T16:18:07.310+02:00 ERROR [CmdLineTool] Plugin "Collector" requires version 2.3.1 - not loading!
2017-09-13T16:18:07.312+02:00 ERROR [CmdLineTool] Plugin "Enterprise Integration Plugin" requires version 2.3.1 - not loading!
2017-09-13T16:18:07.314+02:00 ERROR [CmdLineTool] Plugin "MapWidgetPlugin" requires version 2.3.1 - not loading!
2017-09-13T16:18:07.324+02:00 ERROR [CmdLineTool] Plugin "Pipeline Processor Plugin" requires version 2.3.1 - not loading!
2017-09-13T16:18:07.326+02:00 ERROR [CmdLineTool] Plugin "Anonymous Usage Statistics" requires version 2.3.1 - not loading!

in graylog.jar i can see the file version.properties i don’t understand the problem, can you help me please?

Thanks,


(Jan Doberstein) #2

hej,

was that a fresh installation or an update?

did you reinstall already? It looks like the Package was not installed properly


(oarmand) #3

Hi,

It’s a new installation on new virtual machine, i y tried after others versions but i have the same problem :
graylog-server-2.2.3-1.noarch.rpm : the same problem
graylog-server-2.2.0-11.noarch.rpm : the same problem

i have tried to reinstall graylog-server-2.3.1-1.noarch.rpm and i have the same problem.


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.