Error Accessing Journal API

Hi All,

I’ve just updated to Graylog 3.2.2 running under Docker. After the upgrade, I am getting an error looking at the statistics for my inputs. I cURLed the api URL and I’m getting an error:

"Unable to map property native_lib_dir.\nKnown properties include: flush_interval, plugin_dir, segment_age, max_age, bin_dir, data_dir, max_size, directory, flush_age, segment_size"

Has anyone else seen this error and if so how did you resolve it?


I am having the same issue here after updating to 3.2.2. (Ubuntu install, not Docker) Nothing in the graylog logs. Some related errors in the GUI:

Yes, this is exactly what I’m seeing.

Ok, so it looks like it isn’t specific to Docker since it’s happening on your bare metal install as well as my Docker install.

I also don’t see anything in my logs relating to the journal (other than what appear to be informational messages not related to errors). I also grepped for “native” but didn’t find anything at all.

I guess that this might be this bug:

but not 100% sure with that.

1 Like

Hi Jan,

Looks like a very strong candidate for the cause and fix of this issue. Thanks for pointing this out. Looks like this was / may be ready for the 3.2.3 release.


I’m also seeing this issue on Ubuntu bare metal, but in addition to not being able to hit the Journal API, I also can’t return any search results, on any stream or input. This was just after upgrading to 3.2.2 on a ~1 week old install.

Messages are being appended per the statistics, but search and dashboards all time out.

I am also seeing this error when looking at the node page in the GUI. For me, everything seems to actually be working (searches, dashboards, etc) apart from the error that pops up and the Disk Journal on the node page (as in @tmacgbay’s image above). Am I right to assume that:

  1. I will need to wait for the next release to fix (nothing I can do now).
  2. I am not losing data in the meantime.

Thank you.

Similar issue after updating to 3.2.2, except no messages are being processed,and the journal is throwing the same error:

I’ve tried deleting the journal and restarting to no avail.

I’m also having the same issue. CentOS 7 Standalone Graylog Server ( All in one) Version 3.2.2.

Getting journal information on node 88c91370-15ba-4a01-a0f6-562bdd45440a failed: Error: cannot GET https://FQDN:9000/api/cluster/88c91370-15ba-4a01-a0f6-562bdd45440a/journal (400)

getting this error too, just stumbled upon it now and found this thread, 3.2.2 of course

Same problem here, after update from 3.2.1 to 3.2.2

Is 3.2.2 just broken, or am I missing something?

this is a known issue that will be fixed in 3.2.3

So no work around in the meantime? Can I revert back to 3.2.1 until 3.2.3 is released? Or am I just SOL at the moment?

According to this post: Rollback 3.2->3.1? there is not an implemented feature to rollback Graylog versions. To reference the post:

"About rolling back, if you have made a backup of your mongodb as mentioned in the upgrade nodes you can just use 3.1.x with that backed up database.

Otherwise there is no rollback process implemented in Graylog by now" - @konrad

1 Like

So far I think this is mostly a cosmetic issue. I haven’t seen any issue with the journal capturing messages or in other functionality.

that is true - this is only cosmetic, no functional limitation.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.