E-mail configuration with Office 365 SMTP details


(fala) #1

I build and configure the Graylog server on Ubuntu 16.04 platform. Unfortunately, I do have a problem with configuring alert via e-mail. When I am doing test I do get an error:

The Graylog server encountered an error while trying to send an email. This is the detailed error message: org.apache.commons.mail.EmailException: Sending the email to the following server failed : smtp.office365.com:587 (javax.mail.MessagingException: Could not connect to SMTP host: smtp.office365.com, port: 587; nested exception is: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?)

Please, can you tell me how I can use Office 365 e-mail for alerting. I did use my organisation e-mail address: graylog@********.co.uk


(Jan Doberstein) #2

you could have used the search in this forum, that would have revelead this:

Where you find a working solution.


(fala) #3

Thank you for your reply. As a fact I did look through documentation and I did configure server.conf with office 365 smtp settings and my alert@*****.co.uk email. I can confirm that I can access from my server office 365 smtp service:

telnet smtp.office365.com 578

Connected to outlook-emeawest5.office365.com.

Unfortunately, I can’t run successfully connection test inside the Graylog GUI interface.

Help is much appreciated.

Best Regards


(fala) #4

Sorry I did a typo port 587 is a port I did use inside my server.conf configuration.


(Jan Doberstein) #5

your graylog server.log might reveal the issue. But the configuration that is needed is written down in the linked posting in this community. Including the pitfalls.


(Jochen) #6

(fala) #7

Shortly after I got an error, my server.log file shows as follows:

Does that indicate where is the problem buried?

Best Regards


(Jochen) #8

Yes. Read the post I’ve linked to in my previous reply.


(fala) #9

Hi Jochen

I see it now. Thank you very much. I did post it before I did read your last post ;). Anyway, once again thank you for your contribution.

Best Regards


(fala) #10

Hi Jochen

All is working now. Once again thank you very much.

Best Regards


(system) #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.