Dsiable elasticsearch disk alert

Hi, after upgrading to 3.2.6-1 i receive system alerts about elasticsearch nodes disk usage.
I use several nodes on elastic cluster that does not keep any shards, and used for
hosting Kibana containers only (for monitoring and more comfortable elasticsearch management)
Can i disable these notifications somehow, as they are not relevant ?

Hi @nix-power

Graylog is complaining about disk utilization in the node “”. This one of the nodes you configured to receive data from graylog in your server.conf file in the setting elasticsearch_hosts.

You probably have a index there called “graylog_0” (number here may vary) and it’s a good idea to rotate this index and migrate it to another node with more space.

In graylog.conf i have configured as elasticsearch host http://user:pass@
I have coordinator node running as a docker as a side-car together with graylog container. is a node that runs elasticsearch container and kibana containers only, and in elastricsearch.yaml it has node.data: False setting

Did you make sure that no graylog indexes were created in node

I don’t know, just for double-check purpose.

Just want to add on what @reimlima

If you execute the following command you’ll probably know whats using up space on your volume.

du --max-depth=5 /* | sort -rn | more

1 Like

This node did not keep any indices/shards. Most space was utilized by logs from docker containers.
I cleaned space now, but generally i expect Graylog should check only nodes where actual data reside

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.