Collector-sidecar, beats, hostname, and fqdn


#1

Hi. I’m running into an issue with the collector-sidecar and beats. In the collector_sidecar.yml on both windows and Linux I set the node_id to a fqdn such as app1.company.com.

Under the collectors both windows and linux show up correctly as a fqdn.

Under sources and searches the linux machines show up as a fqdn. Windows shows up as just the hostname for both filebeats and winlogbeats.

Is it possible to force a fqdn in the config?

Jalogisch suggested I create a pipeline rule which is certainly an option. I just wanted to see if a different option is available, possibly in the config itself.