Can't make configuration with log4j work


(Luke) #1

Hi all
I’ve launched a AWS pre installed Graylog instance.
After basic configuration I tried to get some inputs. I need to use log4j to collect data in Graylog so I followed this guide to configure it:

This is my log4j config:
<appender name="graylog2" class="org.graylog2.log.GelfAppender">
<param name="graylogHost" value="172.xx.xx.xx"/>
<param name="graylogPort" value="5140"/>
<param name="facility" value="gelf-java"/>
<param name="Threshold" value="INFO"/>
</appender>

where 172.xx…is private ip of Graylog server

Instance where this configuration is, is on the same network of Graylog server
But when i telnet 172.xx.xx.xx on port 5140I get:
telnet: connect to address 172.xx.xx.xx: Connection refused

This means that it can connect to that ip, but that there is nothing listening on port 5140
I supposed to get something different from telnet here…

I configured input is GL server like this:
Bind address: 0.0.0.0
Port: 5140
other are default values

I see input “Running” but no data is received
What can I check?

Thanks


#2

Not sure I full grasp your problem, but if you Graylog input listens on port 5140, why do you attempt to send your logs to port 12201?


(Luke) #3

I’m sorry, I wrote 12201 while I meant 5140, I’ve just fixed it in my post


(system) closed #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.