3.2 http_bind_address won't resolve hostname

I just installed Graylog 3.2.2 and everything’s working great. I went to enable HTTPS so I followed the guide mentioned here: https://docs.graylog.org/en/3.2/pages/configuration/https.html ( Converting a PKCS #12 (PFX) file to private key and certificate pair ) and then made the necessary changes in server.conf. When I place the key and certificate (both in PEM format) and restart graylog, I just get a white blank page when going to the server on a browser. After some research I found that I needed to have the FQDN in the http_bind_address because that is what I used in the certificate. However, it seems that when I change that from an IP address to the hostname, it doesn’t resolve the IP address and it refuses to load the page. When I put the IP address back in and disable HTTPS, everything works fine again.

Add the FQDN into your /etc/hosts file

Unfortunately, that did not work. Here’s my /etc/hosts file:

::1 localhost6 localhost6.localdomain6 localhost localhost.localdomain hpctest-graylog.example.com hpctest-graylog hpctest-graylog.example.com hpctest-graylog

So I got it to work by placing the IP address back into the server.conf file, but using a different port for https (8443) and opening that port on the machines firewall. Now everything is working great. I guess it doesn’t need the FQDN in the server.conf file like I originally thought.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.