Trying to enable SSL

I mostly followed these instructions to create to configure SSL:

  • openssl genrsa -aes128 -out graylog.key 4096
  • openssl req -sha256 -key graylog.key -new -out graylog.csr -config graylog.cnf
  • openssl pkcs8 -in graylog.key -topk8 -out graylogPKCS8.key
  • keytool -import -trustcacerts -file /etc/ssl/certs/graylog.crt -alias ComodoCA -keystore /etc/graylog/cacerts.jks
  • keytool -list -v -keystore /etc/graylog/cacerts.jks

Graylog isn’t starting and I’m getting this error. Seems like I have all the files in place. Any advice?

2020-02-18T09:07:45.713-05:00 ERROR [ServerBootstrap] Graylog startup failed. Exiting. Exception was:
java.lang.IllegalStateException: Expected to be healthy after starting. The following services are not running: {FAILED=[JerseyService [FAILED]]}
	at$ServiceManagerState.checkHealthy( ~[graylog.jar:?]
	at$ServiceManagerState.awaitHealthy( ~[graylog.jar:?]
	at ~[graylog.jar:?]
	at org.graylog2.bootstrap.ServerBootstrap.startCommand( [graylog.jar:?]
	at [graylog.jar:?]
	at org.graylog2.bootstrap.Main.main( [graylog.jar:?]
	Suppressed:$FailedService: JerseyService [FAILED]
	Caused by: ObjectIdentifier() -- data isn't an object ID (tag = 48)
		at<init>( ~[?:1.8.0_242]
		at ~[?:1.8.0_242]
		at com.sun.crypto.provider.PBES2Parameters.engineInit( ~[sunjce_provider.jar:1.8.0_242]
		at ~[?:1.8.0_242]
		at ~[?:1.8.0_242]
		at<init>( ~[?:1.8.0_242]
		at ~[?:1.8.0_242]
		at javax.crypto.EncryptedPrivateKeyInfo.<init>( ~[?:1.8.0_242]
		at ~[graylog.jar:?]
		at ~[graylog.jar:?]
		at org.graylog2.shared.initializers.JerseyService.buildSslEngineConfigurator( ~[graylog.jar:?]
		at org.graylog2.shared.initializers.JerseyService.startUpApi( ~[graylog.jar:?]
		at org.graylog2.shared.initializers.JerseyService.startUp( ~[graylog.jar:?]
		at$DelegateService$ ~[graylog.jar:?]
		at$ ~[graylog.jar:?]
		at ~[?:1.8.0_242]
2020-02-18T09:07:45.715-05:00 INFO  [Server] SIGNAL received. Shutting down.
2020-02-18T09:07:45.719-05:00 INFO  [GracefulShutdown] Graceful shutdown initiated.
2020-02-18T09:07:45.719-05:00 INFO  [GracefulShutdown] Node status: [Halting [LB:DEAD]]. Waiting <3sec> for possible load balancers to recognize state change.
2020-02-18T09:07:49.721-05:00 INFO  [GracefulShutdown] Goodbye.

he @atrof

and how did you configured http_* parameters in Graylog?


root@graylog:~# cat /etc/graylog/server/server.conf | grep http
# as defined in, using the \u prefix.
# The time zone setting of the root user. See for a list of valid time zones.
#http_bind_address =
#http_bind_address = [2001:db8::1]:9000
http_bind_address =
# This configuration setting has to be used if this Graylog node is available on another network interface than $http_bind_address,
# If $http_bind_address contains a wildcard IPv4 address (, the first non-loopback IPv4 address of this machine will be used.
# Default: http://$http_bind_address/
#http_publish_uri =
http_publish_uri =
# and it will be used to generate URLs addressing entities in the Graylog REST API (see $http_bind_address).
# Default: $http_publish_uri
#http_external_uri =
http_external_url =
#http_enable_cors = false
#http_enable_gzip = false
#http_max_header_size = 8192
#http_thread_pool_size = 16
#http_enable_tls = true
http_enable_tls = true
#http_tls_cert_file = /path/to/graylog.crt
http_tls_cert_file = /etc/ssl/certs/graylog.crt
#http_tls_key_file = /path/to/graylog.key
http_tls_key_file = /etc/graylog/graylog-web8.key
http_tls_key_password = secret_here

did you made the suggested changes to the Graylog Startup script like written in the howto?

Sorry, not sure what you’re referring to. The JVM settings in the documentation, or the JAVA_OPTS in the tutorial above, or something else? Thanks.

I refer to the tutorial you have used …

I ran one more conversion on the pkcs8 key. I noticed it was encrypted, so I made it unencrypted with this command and that worked:
openssl pkcs8 -in graylogPKCS8.key -topk8 -nocrypt -out pkcs8-plain.pem

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.