TCP Syslog does not work

(Sparkkles) #1

Hello ,

I have the 2.5.1 ova of graylog and i send logs from linux Red Hat by syslog to the server.
The server shows logs sent by udp but for tcp i do not have incoming logs.

The rsyslog conf for udp is . @graylog.example.org:5140;
and for tcp : . @@graylog.example.org:5143;
I tried with . @graylog.example.org:5143;RSYSLOG_SyslogProtocol23Format without success

I disabled the firewall on linux and graylog server for the test.

No log input from all sources
#2

@ is for udp and @@ is for tcp.
Do you check if Graylog is listening on TCP 5143 ?
Do you check /var/log/messages or /var/log/syslog if rsyslog says an error ?

(Sparkkles) #3

i tested for tcp both
@@graylog.example.org:5143;
@@graylog.example.org:5143;RSYSLOG_SyslogProtocol23Format

In my graylog client i have input for tcp listening to 5143.
I even tested for tcp on 5140 where udp worked.

On my linux /var/log/syslog i have
“registered tcp module” and “registered udp module”
In /var/log/messages i got “TCP established”

On graylog:

  • /var/log/syslog does not have error
  • /var/log/messages does not exist