Server currently unavailable error after HTTPS activation


#1

After installing a fresh new Graylog instance in AWS with AMI, the server was up and running, and I was able to login to the management portal without encountering any error. I have used the following command (just as the instruction was written) to enable HTTPS:

sudo graylog-ctl enforce-ssl
sudo graylog-ctl reconfigure

sudo graylog-ctl set-external-ip https://xx.xx.xx.xx:443/api
sudo graylog-ctl reconfigure

However, after activating HTTPS, I see that the Graylog server is running, but I am encountering the following error message from the browser:


Server currently unavailable


Error message
Bad request
Original Request
GET https://xx.xx.xx.xx/api/system/sessions
Status code
undefined
Full error message:
Error: Request has been terminated
Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.

There was no error message in graylog server log.
There was an error message in nginx log:

2017/04/14 18:20:18 [error] 8871#0: *7 connect() failed (111: Connection refused) while connecting to upstream, client: xx.xx.xx.xx, server: , request: “GET /favicon.ico HTTP/1.1”, upstream: “http://127.0.0.1:9000/favicon.ico

Note that there was no IP address or host name shown for the “server” in the error message. Could this be the cause of problem? What may be causing this problem?


#2

Fixed problem.
Actual FQDN should be used with “set-external-ip” option.
So it should be: "sudo graylog-ctl set-external-ip https://graylog.example.com:443/api"
Instead of: “sudo graylog-ctl set-external-ip https://xx.xx.xx.xx:443/api

A correction should be made in the HTTPS section in:
http://docs.graylog.org/en/2.2/pages/installation/aws.html