Problem with elasticseach

We gave me a graylog that was supposed to be already installed and functional with the mission of configuring it. However I did not receive any log and I had this error message:
{“type”:“cluster_block_exception”,“reason”:"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"

I learned that it probably came from elasticsearch and so I decided to uninstall it to install elasticsearch-oss.
The problem is that since I did this, although 'elasticsearch seems to be installed correctly, elasticsearch.service failed few seconds after a restart

Thank you in advance for your time

Allow me to ask here because on elasticsearch they have no technical service dedicated to users using the Open Source version

you might want to search this community with your error message and you will see what the problem is with elasticsearch.

Mainly - it was or is out of disk space and went into a read only mode to protect your system from crashing because of a full disk.

Thank you for your anwser

No, I don’t have yet a full disk, it was the case few days ago but I solved this and now I have this problem.

I’ve already watched the forums with the same problem as me, but it didn’t help me solve the problem

No, I don’t have yet a full disk, it was the case few days ago but I solved this and now I have this problem

it looks like you did not make your indices writable again. This is solved in multiple threads in the community.

if I’m not mistaken you’re talking about this order

curl -XPUT -H “Content-Type: application/json” http://localhost:9200/_all/_settings -d ‘{“index.blocks.read_only_allow_delete”: null}’

this give me:
curl: (6) Could not resolve host: application; Unknown error
curl: (7) Failed connect to localhost:9200; Connection refused
curl: (3) [globbing] unmatched close brace/bracket at pos 5

But I notice somethig in the log file of elasticsearch, it seems the the problem is link to java (I think):

Caused by: java.nio.file.AccessDeniedException: /var/lib/elasticsearch/nodes/0/node.lock
at sun.nio.fs.UnixException.translateToIOException( ~[?:?]
at sun.nio.fs.UnixException.rethrowAsIOException( ~[?:?]
at sun.nio.fs.UnixException.rethrowAsIOException( ~[?:?]
at sun.nio.fs.UnixFileSystemProvider.newFileChannel( ~[?:?]
at ~[?:1.8.0_252]
at ~[?:1.8.0_252]

I finally managed to solve the problem with the command:
sudo chown -R elasticsearch:elasticsearch /var/lib/elasticsearch

Just a problem of right
but thanks for your help anyway!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.