Modify Shard number


(Arcocide) #1

Hi,

I have 3 servers for my cluster Graylog2 on Graylog 2.2.3.
I modify the shard number on “Default index set” 4 to 3 because I have my server number 2 that have 2 folder.

How to delete one folder on this server for to have juste one folder by server ?

Regards


(Jan Doberstein) #2

Hej @Groucou

maybe you can describe a little more in detail:

  • what did you have installed
  • what did you change
  • what was the reason for that change
  • what is the exact question

(Arcocide) #3

what did you have installed :

  • 3 Servers Ubuntu 16.04 with cluster Graylog and elasticsearch

what did you change :

  • Number shard elasticsearch 4 to 3

what was the reason for that change :

  • Because i would like to have that all my server have the same size of folder /elasticsearch/graylog-elasticsearch/nodes/0/indices

(Jochen) #4

Please elaborate on that. I don’t understand what you mean.


(Arcocide) #5

I’m sorry,

I juste modify the index shard number since 4 to 3.
But for the moment there are always 4 shard :
image

How to have only 3 shard ? Beacuse I have 3 server.


(Jan Doberstein) #6

hej @Groucou

every new index will only have 3 shards - that setting does not change any of the current available. That is only for new. So you might want to rotate the index to create a new with only the wanted amount of shards.


(system) #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.