Messages not routing into stream


(Jo ) #1

My messages are not routing into streams although the messages match. I have set up the message processors as Message Filter Chain > Pipeline processors to extract a string then convert into a timestamp with the pipeline rules. The streams are to filter the messages depending on the source file name. The messages are showing up in the ‘All messages’ stream. Any ideas?


(Jochen) #2

Yes. Please provide the complete pipeline rules, extractor configurations, and stream rules as well as some example messages and a description of what you’d expect to happen.


(Jo ) #3

I changed the stream rules to ’Field full_message must contain <Channel>Setup</Channel>' in the full message from ’Field System_Channel must contain Setup' and it worked. Not sure why though.

The extractor configuration was a Grok Pattern on the full message for ’<TimeCreated SystemTime=%{QUOTEDSTRING}>' which worked fine once I got the stream working. I used regex as recommended here (Pipeline rule date parse) to create a rule for the pipeline which is working as well.

Am I correct in assuming that an incorrect pipeline would cause the error org.graylog2.periodical.NodePingThread - Did not find meta info of this node. Re-registering? I checked and the time was synced.


(Jan Doberstein) #4

he! @Bumble0b33

org.graylog2.periodical.NodePingThread - Did not find meta info of this node. Re-registering

is something complete different, this indicates that the node itself or one in the cluster has is flapping or under load that the API did not response in time. Sometimes also if the clock in a cluster is not in sync.


(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.