Loadbalancer on Gelf TCP input source IP


We are using a Graylog cluster with Kubernetes with a loadbalancer for inputs.

The problem is the field “source” contain the IP of loadbalancer instead of server source IP.

Is there a a way to fix it ?



I had a similar issue once upon a time and it was an LB setting that needed to be changed, I used nginx so it was proxy_bind $remote_addr transparent: https://stackoverflow.com/questions/42014538/nginx-load-balancer-not-passing-original-ip-address

Check up on the documentation for the load balancer you are using.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.