Issue upgrading Graylog 2.5 to 3 with Docker & Traefik 1.7

Hi all,

I face an issue while upgrading GrayLog from 2.5 to 3.0.0

I have read many posts about issues in this case, and I’m not able to figure out values I’m supposed to set for the Gui.

I understood that with 3.0, HTTP has been simplified, but at this point, I’m stuck with the “blank” homepage issue.

At this point, I’m wondering about the fact that some settings can be made both in


or in docker-compose. The last, as I understand it, supersedes the graylog.conf file.

exemple :

http_bind_address > in graylog.conf

GRAYLOG_HTTP_EXTERNAL_URI > in docker-compose

So the first question is “how and why can I choose to define the value in one place or another ?”.

My environment goes like this :

  Rancher 1.6.26
  Traefik 1.7
  graylog 3.0.0
  elastic search : 5.6.16

Until version 2.5, Traefik made the trick for the port & for https redirect, so my Graylog was reached with this url:

I want to keep this url (https & no port) with version 3.

The traefik labels are set like this :

  traefik.port: '9000'
  traefik.enable: 'true'
  traefik.frontend.headers.SSLRedirect: 'true'

My config is like this :

graylog.conf :

http_bind_address =

docker-compose.yml :


With this conf, I can reach my server with Rancher ip X.X.X.X:9000 but i’m stuck with blank home page with The page source is like this :

<script src=""></script>
<script src=""></script>
<script src=""></script>
<script src=""></script>
<script src=""></script>

Thanks for reading me.


leave that blank that the default is taken (first non loopback ip) - cause that is where Graylog is talking to itself.

The GRAYLOG_HTTP_EXTERNAL_URI is where your Browser is able to reach the Graylog API from your Computer you access Graylog from.

Hi Jan,

Thank you for your message,
it was useful,
I had to remove the publish uri as you said, and also change the external_uri like that


After this everything is ok like before with previous version 2.5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.