Invalid username/password for new users setup through admin

In the logs:
[SessionsResource] Invalid username or password for user “*****”

From the UI:
Invalid credentials, please verify them and retry.

I have setup two new users from the admin ui, being careful in setting and recording their passwords. Neither user’s credentials work. I have reset their passwords multiple times and their credentials still do not work. I have tried using both their username and e-mail, still doesn’t work.

I have existing users in the system with existing passwords that are able to authenticate.

Kind of at a loss on how to proceed here. Running the latest version 3.1.4

I queried users from mongo and all of the passwords take the format of:


however, when I compare the {salt} of the new users to the {salt} of the old users, it differs. Whereas the {salt} on the old users is the same across old users.

I don’t recall changing any settings related to password salts, but the old users were created in Graylog 2.x and the new users in 3.x after upgrading (months ago). What am I missing?

he @bdelamatre

did you have multiple Graylog servers? Do they share the password_secret ( ) ?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.