How to send the log message in the body of the email?

Hey guys,

I am new to GrayLog and I am trying to configure the sending of notifications by email, it sends the logs correctly, however it does not send the message field (Image below) in the body of the email.
How and in what location to define to perform this configuration?

Here is an example e-mail body from our configuration - Note that in this case we use the pipeline to build up a field in the record called email_body that contains consolidated information. We have it set to display that if it exists, otherwise display message.message… which is what you are looking for.

${if stream_url}Stream URL: ${stream_url}${end}
--- [Key Information] ----------------------------

${foreach backlog message}${if message.fields.email_body}${message.fields.email_body}${else}${message.message}${end}

--- [Fields] --------------------------------------
${foreach message.fields field}  ${field.key}:----->${field.value}
${end}
${end}
${if backlog}
--- [Backlog] ------------------------------------${foreach backlog each_message}
-------------[message] ---------------------------

${if each_message.fields.email_body}${each_message.fields.email_body}${else}${each_message.message}${end}

${end}
${end}

In the notification settings, make sure Message Backlog checkbox is enabled.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.