How to disable collectors redirect logs to syslog


(Kyauaa) #1

Hello, I noted that graylog collector in linux platform would redirect its logs to /var/log/message.

example:
[root@vas3 bin]# cat /var/log/messages | grep graylog
Jun 6 09:36:50 vas3 graylog-collector-sidecar: time=“2018-06-06T09:36:50+08:00” level=error msg="[UpdateRegistration] Failed to report collector status to server: Put http://ABC.COM:9000/api/plugins/org.graylog.plugins.collector/collectors/741f2851-6d12-475a-a354-3bdf361ea9ea: read tcp 1.1.1.1:44618->ABC.COM:9000: read: connection reset by peer"

This will trigger my alarm system because of the string “level=error”. Is it possible to disable log redirection to syslog, or downgrade the severity no higher than “warning”

Thanks


(Jochen) #2

No, that’s currently not possible.
Feel free to open a feature request at https://github.com/Graylog2/collector-sidecar/issues.

You could filter messages from the Graylog Collector Sidecar in your syslog daemon, if you absolutely don’t want to be informed about errors.

Example with rsyslog:


(system) #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.