High RAM utilization issue


(Somiya) #1

Hi All,

Currently I am facing an issue of high ram utilization(cached memory) which persist for longer hours.My system configuration as follows:
–> 16GB RAM
–> AMI- amazon ec2

Elasticsearch config as follows:
GRAYLOG_SERVER_JAVA_OPTS="-Xms1g -Xmx1g -XX:NewRatio=1 -server -XX:+ResizeTLAB -XX:+UseConcMarkSweepGC -XX:+CMSConcurrentMTEnabled -XX:+CMSClassUnloadingEnabled -XX:+UseParNewGC -XX:-OmitStackTraceInFastThrow"
So could you please suggest a way forward to overcome this issue.

Thanks and regards


(Jochen) #2

That’s the JVM configuration of Graylog. What about Elasticsearch?

Also, what’s bad about a good utilization of your main memory? Half of what’s used is being used as cache (i. e. disk cache) which speeds up things considerably and zero (0) swap memory is being used.
See https://www.linuxatemyram.com/ for more information.


(Somiya) #3

Hi Jochen,

Please find the elastic search logs as follows:
GRAYLOG_SERVER_JAVA_OPTS="-Xms1g -Xmx1g -XX:NewRatio=1 -server -XX:+ResizeTLAB -XX:+UseConcMarkSweepGC -XX:+CMSConcurrentMTEnabled -XX:+CMSClassUnloadingEnabled -XX:+UseParNewGC -XX:-OmitStackTraceInFastThrow"

Sometimes this issue leads to sever crash.

Thanks and regards


(Jochen) #4

That, again, are the JVM settings of Graylog…


(Somiya) #5

Hi Jochen,

Please find the attachment. I have only mentioned those parameters in the snip where I have changed/uncommented the parameters of server.conf file.

Hope these are the configurations you have asked to provide:slightly_smiling_face:

Regards


(Jan Doberstein) #6

Still that does not cover the JVM Settings of Elasticsearch. Please refer to the documentation where to find them - depending how you installed Graylog.

http://docs.graylog.org/en/2.4/pages/configuration/file_location.html


(Somiya) #7

Hi Jan,

Thanks for guiding please find the attachment:


(Somiya) #8


(system) #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.