Graylog docker-compose Mail alert not working


i run graylog in docker-compose:
image: mongo:4.4
image: graylog/graylog:4.3

I did setup following environment variables:

graylog itself works. Only the alert-mail does not work. If i add an email recipient and try to send an test notification i get the message:
Error: Notification has email recipients and is triggered, but sending emails failed. null

The same thing if i try it with an local user who has an email (User recipient)

When i start a sniffer on the firewall i see no communication via port 587. i have already entered the ip instead of the dns name in GRAYLOG_TRANSPORT_EMAIL_HOSTNAME. Also without success.

I have already tried deactivating the e-mail authentication to check whether packets are sent to the firewall in this way.
But nothing arrived here either.

Has anyone an idea what’s wrong here?

Thanks and best regards,


Hello again,

I found out the following:
If i run the docker-image with version: graylog/graylog:4.2, mail alert works fine with same configuration.
If i upgrade the version from 4.2 to 4.3 i get this error-message in alert mail section:
Loading component failed: Loading chunk 57e33c6c-61 failed. (missing: http://:9000/assets/57e33c6c-61.11b9f72925818240e61d.js)

if i upgrade from 4.2 to 4.3.0 to 4.3.1 mail altert is working. so i must start with latest 4.2 and then upgrade step by step to get mail alert working.

Thanks for posting this,
I have GL Docker instance 4.2. I was going to upgrade but now I know :+1:

If this was the solution, could you mark this as resolved for future search’s?

It’s not a solution, but rather a workaround… but if it’s supposed to be.
Maybe something from Graylog will follow.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.