Graylog Dashboard slow


I have a custom dashboard that is very slow to display.
Refreshing the data is also slow.

Every time I look at the dashboard I have a process that takes 200% of CPU on the server.

Do you have an idea?


@remyrx What is your Graylog and Elasticsearch server CPU and Memory resource allocation? According to snapshot your JVM for ES is 512MB and for Graylog it is 1GB. I guess you need to increase your Graylog and ES server CPU and Memory to get better performance.

@makarands I have reset the default RAM settings for Graylog and Elasticsearch.
The screen was during a test.
Even with the default settings, I still have 200% CPU just in a dashboard.
In the “Search” tab, I never have a CPU increase when I do a search with data refresh per second.

Or can we change the CPU setting for Graylog / Elasticsearch?

Is this bad aggregation manipulation in the dashboard?

@remyrx Yes you need to increase CPU for better performance according to current usage percentage. You can also take look ate below link where you will aware about "How many shards should require to your ES server.

@makarands I put a single index with the number of messages according to my needs.
It’s already better :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.