Graylog-collector-sidecar - no way to clean filebeat registry file


(Andrea) #1

Hi,
atm with graylog-collector-sidecar and filebeat as backend, there’s no way to clean up filebeat registry file (/var/cache/graylog/collector-sidecar/filebeat/data/registry) to prevent it from grows up in time, because in
Graylog -> System/Collectors -> Manage Configurations -> Configure Beats Inputs,
there is no clean_inactive options (ref. https://www.elastic.co/guide/en/beats/filebeat/current/configuration-filebeat-options.html#clean-inactive).

After a long time and expecially with a large number of inputs, filebeat registry file may be a little problem…

May i ask if there is another way (or trick) to clean it up without scheduling a job that stops/clean/start it?

Many thanks in advance, and tnx a lot for Graylog, i love it! :slight_smile:


(Jan Doberstein) #2

@zionio

please open a github issue for this: https://github.com/Graylog2/collector-sidecar/issues

currently I do not know any other way than the one you had described.


(Andrea) #3

Ok, i will.
Tnx a lot! :wink:


(Jan Doberstein) #4

for reference: https://github.com/Graylog2/collector-sidecar/issues/203


(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.