Graylog and Jabber/XMPP


(-mat- filid brandy) #1

I installed the Jabber/XMPP plugin and did configure it according to the notification settings.
The graylog server is able to talk to the server over the given port (so no firewall blocking), but when I trigger a test alert, it does not even try to communicate with the jabber server (tested with tshark).

Any help or documentation on how to use and setup this plugin?

Versions: Graylog 2.4.3+2c41897, Jabber/XMPP Plugin 2.0.0


(Jochen) #2

What’s the complete configuration of the alarm callback?
Does it work when you trigger a test alert?
What’s in the logs of your Graylog node?
:arrow_right: http://docs.graylog.org/en/2.4/pages/configuration/file_location.html


(-mat- filid brandy) #3

The installation of graylog was done on a single VM according to the Debian install guide.
All paths are the standard ones. The jar for the plugin is in the correct directory.
graylogserver and VM are rebooted to ensure a reread of the configs.

Adding a notification setting I’m able to add a Jabber Alarm Callback.
Settings are:


Jabber settings are verified to work.

I don’t see anything in the graylog server logs and I do not see any packets heading to port 5222 via Wireshark.

When I click on “test” I get the following error message I got the above error message.

I’m not seeing this in any logs so far.

Cheers,
-mat-


(-mat- filid brandy) #4

Only thing I see in the logs is:
2018-02-23T10:32:15.534Z INFO [CmdLineTool] Loaded plugin: Jabber Alarmcallback Plugin 2.0.0 [org.graylog2.alarmcallbacks.jabber.JabberAlarmCallback]


(Jochen) #5

Please post the complete logs of your Graylog node.


(-mat- filid brandy) #6

I can’t upload as a new user I’m limited and this prevents the log from being accepted.
You can get it here:
https://www.linuxpinguin.de/20180223-server.log


(Jochen) #7

Could you please check in the developer tools of your web browser in the “Network” tab what the response body of that failed POST request to /api/alerts/callbacks/:id/test is?


(-mat- filid brandy) #8


(-mat- filid brandy) #9

I disabled all filtering plugins in chrome and made sure no proxy in-between


(Jochen) #10

Please check the response in the network tab (not the Javascript error on the console).


(-mat- filid brandy) #11


(-mat- filid brandy) #12


(Jochen) #13

This looks like the following issue on GitHub:


(-mat- filid brandy) #14

I can confirm that going back to the v1.2.1 solved the issue.
Thanks for the great debugging help.

Cheers,
-mat-


(system) #15

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.