Graylog 4.1 on RedHat 8 craches daily

@shoothub @makarands
I made a fresh install on a new server with all default settings for graylog/elastic/mongod following this guide, CentOS installation — Graylog 4.0.0 documentation

Without any logs but its own, the graylog service died the same way.
So now im sure, Graylog on RedHat 8 does not work.

I am running it on CentOS 8, which is free Red Hat. I am not an OS expert to say the true difference. Thank you, Zach.

@dickinsonzach i ran it under CentOS7 without any problems. Then i did a new install with RedHat 8 and that has not worked.

Thanks for replying!
Regards

@Mattias CentOS 8 is compatible with Graylog installation and Graylog document recommending with step by step procedure. AFAIK, you are running Graylog components on the same server, which has 16GB of RAM where you allocated almost 12 GB for JVM (ES and Graylog - 6 GB each), and the remaining 4 GB is OS using it with many services. I would like to request you to check your OS logs (/var/log/messages) where OOM killer might get initiated, and that might kill the process of highly utilized memory.

Also you can check below video for your reference

If you want to add your logs then use FAQ - Graylog Community instructions for better alignment of it.

Thank you, @makarands
I know CentOS 8 is compatible and im running RedHat 8 in production, 1-1 :slight_smile:
I have followed the step by step guide for CentOS as mentioned before.
Now days i have reinstalled graylog and elsatic with default settings and only changed settings (cut and paste) from the installation guide for CentOS and Graylog 4. So graylog has -Xms2g -Xmx2g and elastic has -Xms2g -Xmx2g. Everything is rpm installed. The server now has 20GB RAM and 4+4CPU. The server have not crashed for 36 hours. Now i have a new problem, mongodb is using 100%cpu…
I thinking of setting up a cluster in staid but im not so sure that we will continue with graylog. See under this evaluation i have only tested with 1% of our servers. A log system can never fail. Must be 100% reliable and im not there yet. I will check the video, thanks!

@Mattias Great that your OS crash issue was resolved. If your environment is big, then Graylog recommends for Multi-node setup. You can take a look at the below documentation.

https://docs.graylog.org/en/latest/pages/architecture.html#bigger-production-setup

Also if you want you can get connected with the Graylog sales team for Professional Service

I hope this will helps you!

@makarands Morning, today its dead again. Same problem as always. Can not load streams… “n is undefined” and a stack trace.

I give up! Impossible to find out why it is crashing. Noting to go on i any logs.