Getting error when sending data from AWS Lambda

I am trying to send some sns data via AWS Lambda, it is getting failed almost 70% of the time and I am getting this weird error and not receiving data in graylog, can anyone help me in debugging this.

2021-06-13T14:45:48.780Z ERROR [AbstractTcpTransport] Error in Input [GELF HTTP/60c5f1990db67709da82208f] (channel [id: 0x4e4c9d41, L:/ ! R:/]) (cause io.netty.handler.timeout.ReadTimeoutException)

However, I tried the same setup with google cloud function triggering via pubsub it works perfectly fine.

Just to add on I am using an older version of graylog. i.e. 3.3


From what I can see of what you posted it looks like this post.

Hope that helps

Hello @gsmith , It seems it has been fixed for 3.0.1, but i am still facing the issue in 3.3.2

however, I am facing this issue only while sending data from AWS Lambda to graylog, not while sending data for anywhere else… I tested the same from google cloud functions also where it was working fine.


I’m just going to sum this up for a better understanding.
You have a GELF TCP INPUT, correct?
This input works fine with google cloud BUT not with AWS? If this is correct have you tried to make a separate INPUT for AWS see if that works?
Out of curousity what have you tried to do so far to resolve this issue?
When you stated the following.

Could you elaborate more on this statement?
What would be helpfull is showing your configuration on the GELF input. Also showing more of your Graylog log file.
Do you see any issues in your Elasticsearch log files pertaining to this problem?
Do you see any issues in you MongoDb log files pertaining to this problem?

Hello @gsmith , Thanks for your time. I guess I figured the issue. I was using gelf_http actually. but the issue was with AWS Lambda. I just changed my approach from promises to async/await it started working fine. This can be closed.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.