Elasticsearch Storage


(Shann) #1

Hi!
I am still confused with the storage management of Graylog records. In my case, the elasticsearch storage has been full and it’s not recycling the inputs record to maintain the size of the storage. Elasticsearch server storage has been full and graylog is not sending logs records to elasticsearch server.

How could I fix this problem?

Thanks


(Jochen) #2

Remove some unneeded data, e. g. older Elasticsearch indices.

You can configure this with the rotation and retention strategy settings in the Graylog web interface: http://docs.graylog.org/en/2.2/pages/configuration/index_model.html#index-set-configuration


(Shann) #3

That’s a good start and knowledge for the beginners. Thanks @jochen

I’m learning Graylog’s extreme features to improve the logging systems in my environment.