Elasticsearch cluster unavailable after the changed and make it static


(peter) #1

I got no problem on the first reboot of graylog it using auto obtain ip 11.172.28.145 but when i change the ip and made it static, I got the error Elasticsearch cluster unavailable(Graylog could not successfully connect to the Elasticsearch cluster. If you are using multicast, check that it if working in your network and that Elasticsearch is accessible. Also check that the cluster name setting is correct. Read how to fix this in the Elasticsearch setup documentation.

Error Message:
blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];: cannot GET http://10.172.28.104:9000/api/search/universal/relative?query=*&range=300&limit=150&sort=timestamp%3Adesc (500)
Search status code:
500

Hope, there is somebody who can help me with this issue.

Thanks in Advance.


(Jan Doberstein) #2

hej @peter.legista

I assume that you are using the Graylog appliance? Did you read the documentation to configure static IP on that?

regards
Jan


(peter) #3

Hi @jan

Yes sir, I am using the ova image of the Graylog. and I also follow this Assign a static IP
Per default the appliance make use of DHCP to setup the network. If you want to access Graylog under a static IP please follow these instructions:

$ sudo ifdown eth0
Edit the file /etc/network/interfaces like this (just the important lines):

auto eth0
** iface eth0 inet static**
** address **
** netmask **
** gateway **
** pre-up sleep 2**
Activate the new IP and reconfigure Graylog to make use of it:

sudo ifup eth0** ** sudo graylog-ctl reconfigure
Wait some time until all services are restarted and running again. Afterwards you should be able to access Graylog with the new IP.

But after changing the ip address and made it static, this the start of seeing the error.

Do you have any idea about this issue.

Thanks!


(Jan Doberstein) #4

did you made a full-page reload and connect to the new Graylog IP you had just configured?


(peter) #5

I run the sudo reboot after i have change the ip. Is that the full-page reload you are saying?


(Jan Doberstein) #6

with a full-page reload I refer to your web browser and not the Graylog server.

You pointed your browser to the new configured IP and getting the message that it can’t connect to the old/dynamic ip?


(peter) #7

Yes sir, i open or access the grayloy on the new ip on the web. There is no erro accessing the new ip of graylog on the web, however i always get this Elasticsearch cluster unavailable(Graylog could not successfully connect to the Elasticsearch cluster. If you are using multicast, check that it if working in your network and that Elasticsearch is accessible. Also check that the cluster name setting is correct. Read how to fix this in the Elasticsearch setup documentation. i got no problem when i am not replace the ip.

Have idea?
Thank you.


(peter) #8

The original ip was 11.172.28.179 the i changed it to 11.172.28.102. Now, when i access the Graylog on web using the ip 11.172.28.102 i get this issue.


(Jan Doberstein) #9

did you do the graylog-ctl reconfigure after you had changed the IP the second time?

regards


(peter) #10

yes sir, i execute that command the graylog-ctl configure.


(Jan Doberstein) #11

did you double checked if you had written the IP correct?

The error in the first post say something about:

10.172.28.104


(system) #12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.