Docker image and max_chunk_size


#1

I’m running the latest Docker image of Graylog and using the GELF HTTP input. I’m running into a limitation with the request content size. I’m getting the error:

org.jboss.netty.handler.codec.frame.TooLongFrameException: HTTP content length exceeded 65536 bytes.

I found this past GH issue related to this error, so I figured I could override the default value of 64K by using GRAYLOG_MAX_CHUNK_SIZE.

I tried setting this env variable on the container, but it doesn’t seem to change the setting, so I started digging around in the Graylog Configuration code. I noticed that the config file doesn’t have max_chunk_size in there at all. Does this mean that it’s not possible to override the default value, or am I doing something wrong?


#2

Never mind. Embarrassing. I forgot that when I created the GELF HTTP input, that this was one of the options in the UI.


(system) #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.