Can someone help me with the HTTPS configuration using Apache for API access so Sidecar can use the API over HTTPS?

I am able to make sidecar send logs over HTTP without any issues. But when I am using the HTTPS (Apache) link for API, it’s giving me an error saying “level=error msg=”[UpdateRegistration] Bad response from Graylog server: 404 Not Found" ".
I tried configuring https for API using Keytool and in that case, I am not able to access graylog WebUI. I am completely stuck and need help with this.

Could you share your apache config?

This is the one I used for API. I have one more config Which is working just fine but that’s only for accessing the graylog webUI


Which GL version do you run? After 2.5 or 3.0 the api don’t needed AFAIK.

I am using the latest version of Graylog which 3.2.4

So, in Graylog 3.2.4 how to enable HTPs access for APIs?

the /api part in your proxy config.
Check the GL docs for YOUR gl version.

Thats where I am getting confused. All the Graylog documents talk about setting up proxy for but I am not able to find any document related to API using Apache HTTPS.
If you have a link to the document that I need to go through, it will be of great help if you can share that link with me?


what I usually use:

Okay. Will try.

What method are you using to secure your API? if you are using Apache, can you share your configuration with me?


I use nginx. I use the same config as it in the graylog docs.

Okay. When you use Nginx, does it work for API as well? I mean when you configure Sidecar, do you use https://{API} and it works without any problem?

I don’t use https for sidecars, because I use it for internal usage only.
But /api part of the webpage is available. Eg. api browser, etc.
I suggest use the GL docs, and community forum’s search option. There are a lot of information about the proxys and api access.

1 Like

Got it… Will try to find the solution on google. Thanks…!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.