4.1.2 ; manual index rotate not working

upgraded yesterday from 4.1.0, didn’t try to rotate with that.

Today made a new template for mapping fields and tried to manually rotate to get the new mapping working. It just wont rotate. Tried with FF (which is not working properly with Graylog) and with Chrome.

Main reason for the new mapping was indexing errors:

[995]: index [fortigate_2775], type [_doc], id [e468ef32-f4f1-11eb-90d3-506b8d975db2], message [ElasticsearchException[Elasticsearch exception [type=mapper_parsing_exception, reason=failed to parse field [level] of type [long] in document with id 'e468ef32-f4f1-11eb-90d3-506b8d975db2'. Preview of field's value: 'notice']]; nested: ElasticsearchException[Elasticsearch exception [type=illegal_argument_exception, reason=For input string: "notice"]];]

_template is depracated so made the new mappings (copied and added) to _index_template

Elasticsearch version 7.13

Once again, why you try to use ElasticSearch version which is not supported?

We caution you not to install or upgrade Elasticsearch to 7.11 and later! It is not supported. If you do so, it will break your instance!


The Graylog server application has the following prerequisites:

Elasticsearch 6.8, and version 7 up to 7.10



s¤it, upgraded elastic “by mistake”, did not check… my bad. THANKS for pointing it out.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.