Openstack qcow2 install failing


(Don) #1

I have Graylog installed on Openstack. I created a tenant network with DHCP and assigned a floating IP to it. I can ssh into the instance and I went through the config per the server. I however can not login to the web gui as it never comes up. I get an error and never a login prompt:

Error message
Bad request
Original Request
GET http://172.16.10.10:9000/api/
Status code
undefined
Full error message
Error: Request has been terminated
Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.

Any help would be appreciated,
Don


(Don) #2

I guess I should say that I installed from the image downloaded per the documentation.


(Jochen) #3

Is http://172.16.10.10:9000/api/ the correct URI to the Graylog REST API?

In general, please refer to http://docs.graylog.org/en/2.2/pages/configuration/graylog_ctl.html#configuration-commands for information about how to configure the virtual machine image.


(Don) #4

Yes,172.16.10.10 is the IP of the API but it is not the floating IP. The docs do not distinguish between tenant IP and floating external IP. I could assume that is the same as a proxy/NAT but that does not seem to be working either.


(Jochen) #5

You can set the public IP address of the Graylog REST API which is being used by the Graylog web interface with the following command:

sudo graylog-ctl set-listen-address --service endpoint --address http://<host>:port

(Don) #6

OK, thanks. So it should be the public IP and not the tenant network IP. Let me give that a try. I have tried several combinations of that without success. So I either have to trust I am doing the right thing and look elsewhere or try more combinations. Essentially, 172.16.10.10 is the ip of the tenant network assigned by DHCP and I have another IP from the floating IP pool. So, it will be like this:

sudo graylog-ctl set-listen-address --service endpoint --address http://<Floating IP>:port


(Don) #7

And now the 404 error trying to get to server/sessions.I tried the recommended fix I found at a Stackoverflow but no help. graylog-settings below

 {
  "timezone": "America/Chicago",
  "smtp_server": "",
  "smtp_port": 587,
  "smtp_user": "",
  "smtp_password": "",
  "smtp_from_email": null,
  "smtp_web_url": null,
  "smtp_no_tls": false,
  "smtp_no_ssl": false,
  "master_node": "127.0.0.1",
  "local_connect": false,
  "current_address": "172.16.10.9",
  "last_address": "172.16.10.9",
  "enforce_ssl": false,
  "journal_size": 1,
  "node_id": false,
  "internal_logging": true,
  "web_listen_uri": false,
  "web_endpoint_uri": "http://10.1.34.71:9000",
  "rest_listen_uri": false,
  "rest_transport_uri": false,
  "external_rest_uri": "http://10.1.34.71:9000/api/",
  "custom_attributes": {

  }
}

(Jochen) #8

The web_endpoint_uri setting has to point to the URI of the Graylog REST API.


(Don) #9

10.1.34.71 would be the endpoint URI? Or does it need the :9000?

cat graylog-settings.json
{
  "timezone": "America/Chicago",
  "smtp_server": "",
  "smtp_port": 587,
  "smtp_user": "",
  "smtp_password": "",
  "smtp_from_email": null,
  "smtp_web_url": null,
  "smtp_no_tls": false,
  "smtp_no_ssl": false,
  "master_node": "127.0.0.1",
  "local_connect": false,
  "current_address": "172.16.10.9",
  "last_address": "172.16.10.9",
  "enforce_ssl": false,
  "journal_size": 1,
  "node_id": false,
  "internal_logging": true,
  "web_listen_uri": false,
  "web_endpoint_uri": "http://10.1.34.71:9000/api/",
  "rest_listen_uri": false,
  "rest_transport_uri": false,
  "external_rest_uri": "http://10.1.34.71:9000/api/",
  "custom_attributes": {

  }
}

Tried this as well. Same result.


(Don) #10
{
  "timezone": "America/Chicago",
  "smtp_server": "",
  "smtp_port": 587,
  "smtp_user": "",
  "smtp_password": "",
  "smtp_from_email": null,
  "smtp_web_url": null,
  "smtp_no_tls": false,
  "smtp_no_ssl": false,
  "master_node": "127.0.0.1",
  "local_connect": false,
  "current_address": "172.16.10.9",
  "last_address": "172.16.10.9",
  "enforce_ssl": false,
  "journal_size": 1,
  "node_id": false,
  "internal_logging": true,
  "web_listen_uri": false,
  "web_endpoint_uri": "http://10.1.34.71:9000/api/",
  "rest_listen_uri": false,
  "rest_transport_uri": false,
  "external_rest_uri": "http://10.1.34.71:9000/api/",
  "custom_attributes": {

  }
}

Wierd, Working now. Thanks for your help. Would suggest this needs to be spelled out in the Openstack documentation.


(Jochen) #11

You can improve the documentation at https://github.com/Graylog2/documentation


(Don) #12

Ah, thanks. I will look into that.