Node in GUI showing different values

Hi,

I’m having a strange issue in the graylog web gui when browsing
https://graylog.ourdomain.io/system/nodes/specificnodeID.

The node bar is flapping between different values all the time. When browsing a specific node the bar will flap between different values, like it shows each node (round robin) all the time. And the Disk Journal info is showing 3 different Earliest entry times.

My first thought is that I have made some miss configuration, and something is missing because we are running a ALB in AWS with Round Robin? So the API is asking each node all the time for info and that’s why the node view in the GUI is displaying different info all the time even if I’m just browsing a singel node. We do have sticky sessions enabled in the AWS alb.

Our current Graylog Setup:
Graylog 3.1
3 Graylog nodes
4 separate ES data nodes.
AWS ALB in front of graylog web and api.

server.conf have the following settings for http:

http_bind_address = 0.0.0.0:9000
http_publish_uri = https://graylog.ourdomain.io/
http_external_uri = https://graylog.ourdomain.io/

TL;DR your http_publish_uri is wrong and should be set to an IP accessiable to other graylog nodes. And this config option needs to be set on every node.

Long anser is found in the comment above the publish uri:

#### HTTP publish URI
#
# The HTTP URI of this Graylog node which is used to communicate with the other Graylog nodes in the cluster and by all
# clients using the Graylog web interface.
#
# The URI will be published in the cluster discovery APIs, so that other Graylog nodes will be able to find and connect to this Graylog node.
#
# This configuration setting has to be used if this Graylog node is available on another network interface than $http_bind_address,
# for example if the machine has multiple network interfaces or is behind a NAT gateway.
#
# If $http_bind_address contains a wildcard IPv4 address (0.0.0.0), the first non-loopback IPv4 address of this machine will be used.
# This configuration setting *must not* contain a wildcard address!
#
# Default: http://$http_bind_address/
#http_publish_uri = http://192.168.1.1:9000/

Thanks for the answer.

That did the trick :slight_smile:

1 Like

That’s cool. I will try to enhance the documentation regarding that point.

Yea that would be awesome :smiley:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.