Memory settings for JVM error


i try increase JVM memory for elasticsearch and graylog, but after i use sudo graylog-ctl reconfigure i get this error:

ubuntu@graylog:/etc/graylog$ sudo graylog-ctl reconfigure
Starting Chef Client, version 12.6.0
Compiling Cookbooks…
Recipe: graylog::default

  • directory[/etc/graylog] action create (up to date)

Recipe Compile Error in /opt/graylog/embedded/cookbooks/graylog/recipes/default.rb


parse error: premature EOF
{ “timezone”: “Europe/Prague”
(right here) ------^

Cookbook Trace:

/opt/graylog/embedded/cookbooks/graylog/libraries/graylog.rb:136:in `generate_settings'
/opt/graylog/embedded/cookbooks/graylog/libraries/graylog.rb:237:in `generate_config'
/opt/graylog/embedded/cookbooks/graylog/recipes/default.rb:13:in `from_file'

Relevant File Content:


129: def enabled?(service)
130: Graylog[service.gsub(’-’, ‘_’)][‘enabled’]
131: end
133: def generate_settings
134: existing_settings ||=
135: if File.exists?("/etc/graylog/graylog-settings.json")
136>> existing_settings = Chef::JSONCompat.from_json("/etc/graylog/graylog-settings.json"))
137: end
138: existing_settings.each do |k, v|
139: Graylog[k] = v
140: end
142: Graylog[‘timezone’] = Graylog[:node][‘graylog’][‘timezone’] if Graylog[‘timezone’].empty?
143: Graylog[‘smtp_server’] = Graylog[:node][‘graylog’][‘smtp_server’] if Graylog[‘smtp_server’].nil?
144: Graylog[‘smtp_port’] = Graylog[:node][‘graylog’][‘smtp_port’] if Graylog[‘smtp_port’].nil?
145: Graylog[‘smtp_user’] = Graylog[:node][‘graylog’][‘smtp_user’] if Graylog[‘smtp_user’].nil?

Running handlers:
[2017-10-31T09:15:06+01:00] ERROR: Running exception handlers
Running handlers complete
[2017-10-31T09:15:06+01:00] ERROR: Exception handlers complete
Chef Client failed. 0 resources updated in 02 seconds
[2017-10-31T09:15:06+01:00] FATAL: Stacktrace dumped to /opt/graylog/embedded/cookbooks/cache/chef-stacktrace.out
[2017-10-31T09:15:06+01:00] FATAL: Please provide the contents of the stacktrace.out file if you file a bug report
[2017-10-31T09:15:06+01:00] ERROR: parse error: premature EOF
{ “timezone”: “Europe/Prague”
(right here) ------^

[2017-10-31T09:15:06+01:00] FATAL: Chef::Exceptions::ChildConvergeError: Chef run process exited unsuccessfully (exit code 1)

This is the configuration:

any idea what i bad with timestamp?

add } at the end of file

sorry, that was my bad :slight_smile:
thanks you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.