# Issue with Dashboard after upgrading from 3.1 to 3.2

**URL:** https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994
**Category:** Graylog Central (peer support)
**Created:** [February 17, 2020, 8:28am UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994 "2020-02-17T08:28:17Z")
**Posts on this page:** 13
**Page:** 1

<div class="post-metadata">

### Author: ![vmlenny](https://avatars.discourse-cdn.com/v4/letter/v/dec6dc/32.png) [@vmlenny](https://community.graylog.org/u/vmlenny)
#### Post date: [February 17, 2020, 8:28am UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/1 "2020-02-17T08:28:17Z")

</div>

Hello,

I am getting an error as below while opening the dashboard tab after upgrading from 3.1 to 3.2

Could not retrieve dashboards  
Fetching dashboards failed with status: Error: cannot GET [http://serverip:9000/api/views/dashboards?query=&page=1&per\_page=10&sort=title&order=asc](http://serverip:9000/api/views/dashboards?query=&page=1&per_page=10&sort=title&order=asc) (500)

I also get this error while i try to edit a profile.

Previously certain dashboard were created and assigned to certain roles for non admin users

Currently using the API I have deleted all the dashboards and still I get the error

Graylog version : 3.2.1+dbaac33, codename _Ethereal Elk_  
Upgraded from : 3.1.4+1149fe1, codename _Quantum Dog_  
Elastic version : 6.8.3  
OS : CentOS Linux release 7.7.1908 (Core)

Any guidance would be appreciated.  
Thank you

---

<div class="post-metadata">

### Author: ![vmlenny](https://avatars.discourse-cdn.com/v4/letter/v/dec6dc/32.png) [@vmlenny](https://community.graylog.org/u/vmlenny)
#### Post date: [February 17, 2020, 8:39am UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/2 "2020-02-17T08:39:44Z")

</div>

In the log file I ran the below command

[root@graylogsrv graylog-server]# cat server.log | grep -i migration | grep -i error

I get only the below error

2020-02-10T15:26:07.152+03:00 ERROR [MigrationHelpers] Invalid role ‘Views Manager’, fixing it

---

<div class="post-metadata">

### Author: ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)
#### Post date: [February 17, 2020, 12:53pm UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/3 "2020-02-17T12:53:45Z")

</div>

he @vmlenny

did you see any information about migration in the first startup logfile of Graylog after the update?

did you restart Graylog after you have deleted the dashboards?

---

<div class="post-metadata">

### Author: ![vmlenny](https://avatars.discourse-cdn.com/v4/letter/v/dec6dc/32.png) [@vmlenny](https://community.graylog.org/u/vmlenny)
#### Post date: [February 17, 2020, 4:15pm UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/4 "2020-02-17T16:15:04Z")

</div>

@jan thank for you response.

The same error is there on the user profile page and I am not able to edit any user  
and the dashboard page get stuck in “Loading views…”  
Tried creating a simple count dashboard it successfully saves but when i go back to the dashboard page it does not load

did you see any information about migration in the first startup logfile of Graylog after the update?  
below is the log i can find  
2020-02-10T09:48:29.491+03:00 INFO [Periodicals] Starting [org.graylog.plugins.pipelineprocessor.periodical.LegacyDefaultStreamMigration] periodical, running forever.  
2020-02-10T09:48:29.566+03:00 INFO [LegacyDefaultStreamMigration] Legacy default stream has no connections, no migration needed.  
2020-02-10T09:48:29.587+03:00 INFO [Periodicals] Starting [org.graylog2.periodical.IndexRangesMigrationPeriodical] periodical, running forever.  
2020-02-10T09:48:29.669+03:00 INFO [PeriodicalsService] Not starting [org.graylog2.periodical.UserPermissionMigrationPeriodical] periodical. Not configured to run on this node.

did you restart Graylog after you have deleted the dashboards?  
Yes the server was restarted after the dashboards were deleted

Thank you

---

<div class="post-metadata">

### Author: ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)
#### Post date: [February 18, 2020, 10:23am UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/5 "2020-02-18T10:23:51Z")

</div>

sorry - i have no idea how to solve that situation.

maybe @konrad?

---

<div class="post-metadata">

### Author: ![konrad](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/konrad/32/1661_2.png) [@konrad](https://community.graylog.org/u/konrad)
#### Post date: [February 18, 2020, 10:33am UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/6 "2020-02-18T10:33:00Z")

</div>

Hello @vmlenny,

when you get the error, can you please take a look into the web dev console (usually reachable with `F12`)

There should be a line which is containing sometimes additional messages (like stack traces) to the error.

I am pretty sure you did already but just in case, did you take a look in to the server.log right after you clicked on the dashboards overview page to see if a stack trace can be found there?

---

<div class="post-metadata">

### Author: ![vmlenny](https://avatars.discourse-cdn.com/v4/letter/v/dec6dc/32.png) [@vmlenny](https://community.graylog.org/u/vmlenny)
#### Post date: [February 19, 2020, 5:39am UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/7 "2020-02-19T05:39:38Z")

</div>

@jan thank you for the efforts

@konrad

The below is the error i get form the web dev console

There was an error fetching a resource: cannot GET [http://serverip:9000/api/views/dashboards?query=&page=1&per\_page=10&sort=title&order=asc](http://serverip:9000/api/views/dashboards?query=&page=1&per_page=10&sort=title&order=asc) (500). Additional information: IOException encountered while reading from a byte array input stream

Below is the extract from the server.log… any suggestion as what to look for would be appreciated

[https://pastebin.com/raw/3PtfR6Jy](https://pastebin.com/raw/3PtfR6Jy)

---

<div class="post-metadata">

### Author: ![konrad](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/konrad/32/1661_2.png) [@konrad](https://community.graylog.org/u/konrad)
#### Post date: [February 19, 2020, 9:05am UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/8 "2020-02-19T09:05:46Z")

</div>

Hi @vmlenny,

it seems the migration did something wrong here. We migrated the dashboards to views. Views are now dashboards. We can go now different roads to a solution.

1. If you do not care about your saved searches and dashboards you could delete all of your mongodb documents of `views`.
2. If you want to keep them and are you do not have a problem in sharing them, you can export them and show them to me and we try to fix the problem.
3. You can fix it by yourself by going though your mongodb `views` documents and searching for the interval. One interval has a unit set which is not in the right format:

```auto
where quantity is a positive number and unit [smhdwM]

```

 ![collection](https://us1.discourse-cdn.com/flex016/uploads/graylog/original/2X/8/856434820662b25895b7028ef3b55a4df5a9432d.png)

- Konrad

---

<div class="post-metadata">

### Author: ![vmlenny](https://avatars.discourse-cdn.com/v4/letter/v/dec6dc/32.png) [@vmlenny](https://community.graylog.org/u/vmlenny)
#### Post date: [February 19, 2020, 12:01pm UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/9 "2020-02-19T12:01:43Z")

</div>

@konrad

You solution was spot on. I deleted the document from mongodb and it fixed the issue

Thanks alot for your support

---

<div class="post-metadata">

### Author: ![konrad](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/konrad/32/1661_2.png) [@konrad](https://community.graylog.org/u/konrad)
#### Post date: [February 19, 2020, 12:03pm UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/10 "2020-02-19T12:03:09Z")

</div>

@vmlenny, did you by chance see what was the content of the interval? So I can tyr to ivestigate what went wrong?

Happy that we got it working for you!

- Konrad

---

<div class="post-metadata">

### Author: ![vmlenny](https://avatars.discourse-cdn.com/v4/letter/v/dec6dc/32.png) [@vmlenny](https://community.graylog.org/u/vmlenny)
#### Post date: [February 19, 2020, 12:39pm UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/11 "2020-02-19T12:39:16Z")

</div>

@konrad

I am sorry did not look into the interval. I Just deleted the first dashboard and it worked.  
I know i should have looked at it before deleting.

Thank you again

Lenny

---

<div class="post-metadata">

### Author: ![laakkus](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/laakkus/32/3060_2.png) [@laakkus](https://community.graylog.org/u/laakkus)
#### Post date: [February 25, 2020, 7:07pm UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/12 "2020-02-25T19:07:01Z")

</div>

I have the similar issue, trying to find “wrong” in interval… WHAT is the wrong? scaling : null ??  
Lots of clicking…

Just installed robo 3T and not sure how to use this (SQL to mongo):

> [@konrad](#):
>
> where quantity is a positive number and unit [smhdwM]

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex016/uploads/graylog/original/3X/c/7/c7c09c6b5099570133d6502b83f50ba4430de5b6.png) [@system](https://community.graylog.org/u/system)
#### Post date: [March 10, 2020, 7:07pm UTC](https://community.graylog.org/t/issue-with-dashboard-after-upgrading-from-3-1-to-3-2/13994/13 "2020-03-10T19:07:01Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
