Is there a way of disabling all inputs on a particular node


(Steven Cherry) #1

Hi All, I’m using docker to run Graylog in AWS using their ECS service.

I have individual containers dedicated to serving the UI, Master node as well as message processing nodes. The message processing nodes autoscale according to demand. Here’s my problem, I can’t using local inputs attached to particular processing nodes since they are transient and come and go according to demand. If I use global inputs the UI and master nodes will start the input and potentially start processing messages.

Is there a way that I mark a node to not start any inputs, even global inputs?


(Jan Doberstein) #2

He @steven.cherry

this is currently not possible. You would need to ensure by your architecture design that processing is not happening on a node you do not want to.

In addition, you might want to write a feature issue for that over at Github for that: https://github.com/Graylog2/graylog2-server/issues


(Steven Cherry) #3

Thanks for the reply Jan. In light of your response I have another question.

If I disable message processing on a particular node and it has a ‘pull’ type input, for example the ‘AWS Logs’ which connects to AWS kinesis. Will the node still pull messages and queue them in the journal or stop pulling all together?

Thanks again