How to mark a Lookup table inactive


(Jake Smith) #1

Hi All,

I was looking to delete a lookup table, however when I tried to delete it, there is an error telling me it is active and cant be deleted. Also the cache and data adapter are also marked active and cant be deleted as they are attached to an active lookup table.

How do I mark a lookup table inactive so that I can delete it and recreate it.

Jake


(Kay Roepke) #2

Hi Jake!

A lookup table should be deletable in all circumstances, because there is currently no check if some rule or other part of the system is using it (mostly because we lack a place for plugins to register their “usage”).

Adapters and caches can only be deleted if no lookup table is using them, that check is performed because otherwise it would be too easy to break the system.

Could you attach a screenshot of what happens when you try to delete the lookup table, please?
If you don’t like to share that here, you can also send me an email at kay@graylog.com to help me debug this issue.

Thanks!


(Jake Smith) #3

Hi Kay,

Weird result, there was a red warning each time i tried to delete it yesterday saying it was in use.

However, i just started my VM and tried it again so that I could get you a screenshot but it deleted it fine.

I have checked in server.log as well and cant find any mention apart from JSON parser errors due to me not understanding how to restore dashboards etc. There are also no errors in the Gui logs showing issues.

I will wait and see if it happens again, otherwise I will put it down to me meddling with VM lots as I was changing IP address configuration as well.

Sorry the false report

Jake


(Kay Roepke) #4

Jake, good to hear!

Better one report too many than one bug too many!
Please let me know if you find anything broken.

Thanks!


(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.