Heap Size with OVA Appliance


(meg) #1

Can you increase heap size with OVA appliance? Read the documentation and tried to change the heap size and I am thrown an error after reconfiguration.


#2

There is a ‘good’ way and ‘bad’ way to set the OVA heap size.
The best (and supported way) is to edit the file /etc/graylog/graylog-settings.json with values similar to the ones below;

{
  "timezone": "Australia/Perth",
  "smtp_server": "mail.xxxx.com",
  "smtp_port": 25,
  "smtp_user": "",
  "smtp_password": "",
  "smtp_from_email": "prod_graylog",
  "smtp_web_url": null,
  "smtp_no_tls": false,
  "smtp_no_ssl": false,
  "master_node": "192.168.0.1",
  "local_connect": false,
  "current_address": "192.168.0.1",
  "last_address": "192.168.0.1",
  "enforce_ssl": false,
  "journal_size": 4,
  "node_id": false,
  "internal_logging": true,
  "web_listen_uri": false,
  "web_endpoint_uri": false,
  "rest_listen_uri": "http://0.0.0.0:12900/api",
  "rest_transport_uri": false,
  "external_rest_uri": false,
  "custom_attributes": {
    "graylog-server": {
      "memory": "3000m",
      "elasticsearch_cluster_name": "pgraylog",
      "processbuffer_processors": 8
    },
    "elasticsearch": {
      "cluster_name": "pgraylog",
      "data_directory": "/graylog-data/elasticsearch"
    }
  }
}

The value you want to set is ‘memory’ and ensure that the virtual machine has enough memory allocated to it.
Use the command ‘sudo graylog-ctl reconfigure’ to set the heap size memory.By using this method the values are also retained across the use of the command 'sudo graylog-ctl reconfigure’
See the documentation at http://docs.graylog.org/en/2.2/pages/configuration/graylog_ctl.html#graylog-ctl-advanced
and click on the ‘attributes’ link for further information.

I won’t elaborate on the 'bad way.

Regards,

Harry W.


(meg) #3

After configuring the file how you have it but with my settings. It is still throwing an error.


(Jan Doberstein) #4

hej @flowersme when you elaborate on this someone might help you …


(meg) #5

Here is the error.


(Jan Doberstein) #6

did you do a brief syntax check?

you are having a , after your processbuffer_processors: 8 and that is not the place to have that …