# Graylog service failed

**URL:** https://community.graylog.org/t/graylog-service-failed/3350
**Category:** Graylog Central (peer support)
**Created:** [November 30, 2017, 4:58pm UTC](https://community.graylog.org/t/graylog-service-failed/3350 "2017-11-30T16:58:54Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![garone](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/garone/32/1308_2.png) [@garone](https://community.graylog.org/u/garone)
#### Post date: [November 30, 2017, 4:58pm UTC](https://community.graylog.org/t/graylog-service-failed/3350/1 "2017-11-30T16:58:54Z")

</div>

I have one graylog 2.3.1 up and running ok in CentOS 7 - 1406 updated to last ups.  
Now I has instaled Graylog 2.3.2 in CentOS 7.1406 but graylog-server.service cant run…

Message: `systemctl status graylog-server.service`:

```nohighlight
[root@LOG1 graylog-server]# systemctl status graylog-server
graylog-server.service - Graylog server
   Loaded: loaded (/usr/lib/systemd/system/graylog-server.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Qui 2017-11-30 14:51:57 BRST; 2s ago
     Docs: http://docs.graylog.org/
  Process: 4150 ExecStart=/usr/share/graylog-server/bin/graylog-server (code=exited, status=1/FAILURE)
 Main PID: 4150 (code=exited, status=1/FAILURE)

Nov 30 14:51:57 LOG1.blausiegel.local systemd[1]: graylog-server.service: main process exited, code=exited, status=1/FAILURE
Nov 30 14:51:57 LOG1.blausiegel.local systemd[1]: Unit graylog-server.service entered failed state.

```

LOGs: `/var/log/graylog-server` - last lines - same hour:

```nohighlight
2017-11-30T14:51:43.424-02:00 INFO [CmdLineTool] Loaded plugin: Elastic Beats Input 2.3.2 [org.graylog.plugins.beats.BeatsInputPlugin]
2017-11-30T14:51:43.427-02:00 INFO [CmdLineTool] Loaded plugin: Collector 2.3.2 [org.graylog.plugins.collector.CollectorPlugin]
2017-11-30T14:51:43.427-02:00 INFO [CmdLineTool] Loaded plugin: Enterprise Integration Plugin 2.3.2 [org.graylog.plugins.enterprise_integration.EnterpriseIntegrationPlugin]
2017-11-30T14:51:43.428-02:00 INFO [CmdLineTool] Loaded plugin: MapWidgetPlugin 2.3.2 [org.graylog.plugins.map.MapWidgetPlugin]
2017-11-30T14:51:43.439-02:00 INFO [CmdLineTool] Loaded plugin: Pipeline Processor Plugin 2.3.2 [org.graylog.plugins.pipelineprocessor.ProcessorPlugin]
2017-11-30T14:51:43.441-02:00 INFO [CmdLineTool] Loaded plugin: Anonymous Usage Statistics 2.3.2 [org.graylog.plugins.usagestatistics.UsageStatsPlugin]
2017-11-30T14:51:43.500-02:00 ERROR [CmdLineTool] Invalid configuration
com.github.joschi.jadconfig.ValidationException: Unreadable or missing REST API private key: /etc/graylog/server/cert/graylog.key
	at org.graylog2.plugin.BaseConfiguration.validateRestTlsConfig(BaseConfiguration.java:456) ~[graylog.jar:?]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_151]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_151]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_151]
	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_151]
	at com.github.joschi.jadconfig.ReflectionUtils.invokeMethodsWithAnnotation(ReflectionUtils.java:53) ~[graylog.jar:?]
	at com.github.joschi.jadconfig.JadConfig.invokeValidatorMethods(JadConfig.java:221) ~[graylog.jar:?]
	at com.github.joschi.jadconfig.JadConfig.process(JadConfig.java:100) ~[graylog.jar:?]
	at org.graylog2.bootstrap.CmdLineTool.processConfiguration(CmdLineTool.java:351) [graylog.jar:?]
	at org.graylog2.bootstrap.CmdLineTool.readConfiguration(CmdLineTool.java:344) [graylog.jar:?]
	at org.graylog2.bootstrap.CmdLineTool.run(CmdLineTool.java:177) [graylog.jar:?]
	at org.graylog2.bootstrap.Main.main(Main.java:44) [graylog.jar:?]
2017-11-30T14:51:57.120-02:00 INFO [CmdLineTool] Loaded plugin: Elastic Beats Input 2.3.2 [org.graylog.plugins.beats.BeatsInputPlugin]
2017-11-30T14:51:57.122-02:00 INFO [CmdLineTool] Loaded plugin: Collector 2.3.2 [org.graylog.plugins.collector.CollectorPlugin]
2017-11-30T14:51:57.123-02:00 INFO [CmdLineTool] Loaded plugin: Enterprise Integration Plugin 2.3.2 [org.graylog.plugins.enterprise_integration.EnterpriseIntegrationPlugin]
2017-11-30T14:51:57.124-02:00 INFO [CmdLineTool] Loaded plugin: MapWidgetPlugin 2.3.2 [org.graylog.plugins.map.MapWidgetPlugin]
2017-11-30T14:51:57.133-02:00 INFO [CmdLineTool] Loaded plugin: Pipeline Processor Plugin 2.3.2 [org.graylog.plugins.pipelineprocessor.ProcessorPlugin]
2017-11-30T14:51:57.135-02:00 INFO [CmdLineTool] Loaded plugin: Anonymous Usage Statistics 2.3.2 [org.graylog.plugins.usagestatistics.UsageStatsPlugin]
2017-11-30T14:51:57.192-02:00 ERROR [CmdLineTool] Invalid configuration
com.github.joschi.jadconfig.ValidationException: Unreadable or missing REST API private key: /etc/graylog/server/cert/graylog.key
	at org.graylog2.plugin.BaseConfiguration.validateRestTlsConfig(BaseConfiguration.java:456) ~[graylog.jar:?]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_151]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_151]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_151]
	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_151]
	at com.github.joschi.jadconfig.ReflectionUtils.invokeMethodsWithAnnotation(ReflectionUtils.java:53) ~[graylog.jar:?]
	at com.github.joschi.jadconfig.JadConfig.invokeValidatorMethods(JadConfig.java:221) ~[graylog.jar:?]
	at com.github.joschi.jadconfig.JadConfig.process(JadConfig.java:100) ~[graylog.jar:?]
	at org.graylog2.bootstrap.CmdLineTool.processConfiguration(CmdLineTool.java:351) [graylog.jar:?]
	at org.graylog2.bootstrap.CmdLineTool.readConfiguration(CmdLineTool.java:344) [graylog.jar:?]
	at org.graylog2.bootstrap.CmdLineTool.run(CmdLineTool.java:177) [graylog.jar:?]
	at org.graylog2.bootstrap.Main.main(Main.java:44) [graylog.jar:?]

```

Any ideias?

thanks,

---

<div class="post-metadata">

### Author: ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)
#### Post date: [November 30, 2017, 6:36pm UTC](https://community.graylog.org/t/graylog-service-failed/3350/2 "2017-11-30T18:36:33Z")

</div>

you should check line 55 in your graylog server.conf

> <https://github.com/Graylog2/graylog2-server/blob/2.3/misc/graylog.conf#L55>

or your graylog server.conf in general

---

<div class="post-metadata">

### Author: ![garone](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/garone/32/1308_2.png) [@garone](https://community.graylog.org/u/garone)
#### Post date: [November 30, 2017, 8:46pm UTC](https://community.graylog.org/t/graylog-service-failed/3350/3 "2017-11-30T20:46:28Z")

</div>

Hi Jan,  
Yep, I configured both the passwords: password secret and root\_password sha2, and the rest\_listen\_uri and web\_listen\_uri information but still the service does not go up and the same error remains…  
thanks,

---

<div class="post-metadata">

### Author: ![jochen](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jochen/32/8_2.png) [@jochen](https://community.graylog.org/u/jochen)
#### Post date: [December 1, 2017, 8:04am UTC](https://community.graylog.org/t/graylog-service-failed/3350/4 "2017-12-01T08:04:19Z")

</div>

> [@garone](#):
>
> ```plaintext
> com.github.joschi.jadconfig.ValidationException: Unreadable or missing REST API private key: /etc/graylog/server/cert/graylog.key
> 
> ```

There’s your problem…

---

<div class="post-metadata">

### Author: ![garone](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/garone/32/1308_2.png) [@garone](https://community.graylog.org/u/garone)
#### Post date: [December 4, 2017, 8:40pm UTC](https://community.graylog.org/t/graylog-service-failed/3350/5 "2017-12-04T20:40:55Z")

</div>

Thanks joschen and Jan.  
Issue resolved.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex016/uploads/graylog/original/3X/c/7/c7c09c6b5099570133d6502b83f50ba4430de5b6.png) [@system](https://community.graylog.org/u/system)
#### Post date: [December 18, 2017, 8:40pm UTC](https://community.graylog.org/t/graylog-service-failed/3350/6 "2017-12-18T20:40:56Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
