Graylog OVA image on virtualbox problem connecting to elasticsearch


(Paul ) #1

I have downloaded a couple of the OVA images and tried importing them into Virtualbox.

I can’t run the VM in bridged network mode owing to the wifi network in our office not allocating IPs without jumping through hoops so I’ve tried in NAT and NAT network modes.

These appear to start but then the web interface fails and when I look in the log file /var/log/graylog/server/current it is saying that a connection to the VMs IP address on port 9200 is being refused.

Caused by: org.apache.http.conn.HttpHostConnectException: Connect to 10.0.2.15:9000 [/10.0.2.15] failed: Connection refused (Connection refused)

However elasticsearch is running because I can see it in netstat and connect to it with curl.

curl -X GET http://10.0.2.15:9200/_cat/health
1502875432 09:23:52 graylog yellow 1 1 4 4 0 0 4 0 - 50.0%

I’m assuming this is something weird to do with the virtual box networking and am certain someone will have tried it before and have a solution.

Virtualbox 5.1.26
Mac os 10.12.6


(system) #2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.