Graylog on CentOS7 in Google Cloud


(Raleigh Guevarra) #1

Newly installed ElasticSearch/Graylog on CentOS7 in Google Cloud. The web interface is inaccessible. I checked the log tailf /var/log/graylog-server/server.log and it says that Invalid configuration and Cannot read file elasticsearch_config_file…

2017-07-20T07:50:36.694Z INFO [CmdLineTool] Loaded plugin: Elastic Beats Input 2.2.3 [org.graylog.plugins.beats.BeatsInputPlugin]
2017-07-20T07:50:36.696Z INFO [CmdLineTool] Loaded plugin: Collector 2.2.3 [org.graylog.plugins.collector.CollectorPlugin]
2017-07-20T07:50:36.699Z INFO [CmdLineTool] Loaded plugin: Enterprise Integration Plugin 2.2.3 [org.graylog.plugins.enterprise_integration.EnterpriseIntegrationPlugin]
2017-07-20T07:50:36.700Z INFO [CmdLineTool] Loaded plugin: MapWidgetPlugin 2.2.3 [org.graylog.plugins.map.MapWidgetPlugin]
2017-07-20T07:50:36.708Z INFO [CmdLineTool] Loaded plugin: Pipeline Processor Plugin 2.2.3 [org.graylog.plugins.pipelineprocessor.ProcessorPlugin]
2017-07-20T07:50:36.709Z INFO [CmdLineTool] Loaded plugin: Anonymous Usage Statistics 2.2.3 [org.graylog.plugins.usagestatistics.UsageStatsPlugin]
2017-07-20T07:50:36.813Z ERROR [CmdLineTool] Invalid configuration
com.github.joschi.jadconfig.ValidationException: Cannot read file elasticsearch_config_file at path /etc/elasticsearch/elasticsearch.yml. Please specify the correct path or change the permissions
at com.github.joschi.jadconfig.validators.FilePathReadableValidator.validate(FilePathReadableValidator.java:16) ~[graylog.jar:?]
at com.github.joschi.jadconfig.validators.FilePathReadableValidator.validate(FilePathReadableValidator.java:9) ~[graylog.jar:?]
at com.github.joschi.jadconfig.JadConfig.validateParameter(JadConfig.java:215) ~[graylog.jar:?]
at com.github.joschi.jadconfig.JadConfig.processClassFields(JadConfig.java:148) ~[graylog.jar:?]
at com.github.joschi.jadconfig.JadConfig.process(JadConfig.java:99) ~[graylog.jar:?]
at org.graylog2.bootstrap.CmdLineTool.processConfiguration(CmdLineTool.java:351) [graylog.jar:?]
at org.graylog2.bootstrap.CmdLineTool.readConfiguration(CmdLineTool.java:344) [graylog.jar:?]
at org.graylog2.bootstrap.CmdL...(CmdLineTool.java:177) [graylog.jar:?]
at org.graylog2.bootstrap.Main.main(Main.java:44) [graylog.jar:?]

Is there a permission issue?

/etc/elasticsearch
# ls -lrtha
-rwxr-x---. 1 root elasticsearch 2.6K Apr 24 16:04 logging.yml
drwxr-x---. 2 root elasticsearch 6 Apr 24 16:29 scripts
-rwxr-x---. 1 root elasticsearch 3.2K Jul 20 05:05 elasticsearch.yml

Please help, thanks in advance.


(Jochen) #2

Are you 100% sure that you need to specify the elasticsearch_config_file setting? It’s probably not what you think it is…


(system) #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.