# Graylog error: loading field information failed with status 500

**URL:** <https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591>\
**Category:** Graylog Central (peer support)\
**Created:** [January 30, 2019, 8:16am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591 "2019-01-30T08:16:42Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bahman](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@Bahman](https://community.graylog.org/u/Bahman)\
**Post date:** [January 30, 2019, 8:16am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/1 "2019-01-30T08:16:42Z")

</div>

I try to upgrade graylog in docker from version 2.2.3-1 to 2.4.6-1 on ubuntu .  
i used following command  
docker run --link mongo --link elasticsearch -p 9000:9000 -p 12201:12201 -p 1514:1514 -e GRAYLOG\_WEB\_ENDPOINT\_URI=“[http://my-ip:9000/api](http://my-ip:9000/api)” -d graylog/graylog:2.4.6-1  
after that i start docker-compose up -d  
and login to gralog.  
det problem is i can’t search.

---

<div class="post-metadata">

**Author:** ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)\
**Post date:** [January 30, 2019, 9:28am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/2 "2019-01-30T09:28:14Z")

</div>

what is the error you are facing?

Did you checked the upgrade nodes for breaking changes?

[http://docs.graylog.org/en/2.5/pages/upgrade.html](http://docs.graylog.org/en/2.5/pages/upgrade.html)

---

<div class="post-metadata">

**Author:** ![Bahman](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@Bahman](https://community.graylog.org/u/Bahman)\
**Post date:** [January 30, 2019, 9:39am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/3 "2019-01-30T09:39:06Z")

</div>

yes i did. mongo is version 3, and elasticsearch is version 2. It’s support elasticsearch version 2X.  
Error is unable to perform search query. and search status code is 500.  
search respond is  
cannot GET http://“server-name”:9000/api/search/universal/relative?query=bolig&range=300&limit=150&sort=timestamp%3Adesc (500)

---

<div class="post-metadata">

**Author:** ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)\
**Post date:** [January 30, 2019, 9:41am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/4 "2019-01-30T09:41:42Z")

</div>

did you notice the changes in 2.3 ( [http://docs.graylog.org/en/2.5/pages/upgrade/graylog-2.3.html](http://docs.graylog.org/en/2.5/pages/upgrade/graylog-2.3.html) ) the changed way Graylog connects to Elasticsearch.

Also the special note what you need todo after you upgrade graylog?

---

<div class="post-metadata">

**Author:** ![Bahman](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@Bahman](https://community.graylog.org/u/Bahman)\
**Post date:** [January 30, 2019, 9:47am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/5 "2019-01-30T09:47:41Z")

</div>

no. it’s look like i need to upgrade elasticsearch.

---

<div class="post-metadata">

**Author:** ![Bahman](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@Bahman](https://community.graylog.org/u/Bahman)\
**Post date:** [January 30, 2019, 12:02pm UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/6 "2019-01-30T12:02:26Z")

</div>

ok i rebuild elasticsearch and upgrade elaticsearch to 6.5.4  
i try to login to graylog i get error: The server returned : 400 - cannot post http:“servername”:9000/api/system/session (400)

Please Help!

---

<div class="post-metadata">

**Author:** ![Bahman](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@Bahman](https://community.graylog.org/u/Bahman)\
**Post date:** [January 30, 2019, 12:06pm UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/7 "2019-01-30T12:06:06Z")

</div>

ok i login should write domain name also. but the same problem cannot search and search code s 500

---

<div class="post-metadata">

**Author:** ![Bahman](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@Bahman](https://community.graylog.org/u/Bahman)\
**Post date:** [January 30, 2019, 12:14pm UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/8 "2019-01-30T12:14:46Z")

</div>

Loading of sources data failed with status : error: cannot Get http://…:900/api/sources?range=3600 (500). Try reloading the page.

and

could not retriev index.sets.  
feaching index sets list failed: unable to read information for indices [graylog\_\*]

---

<div class="post-metadata">

**Author:** ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)\
**Post date:** [January 30, 2019, 2:13pm UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/9 "2019-01-30T14:13:43Z")

</div>

it looks like your Graylog is not able to connect to your Elasticsearch.

Without knowing your configuration it is not possible to help you in any other way than pointing to the documentation and the docker setup page where working configs are given:

[http://docs.graylog.org/en/2.5/pages/installation/docker.html](http://docs.graylog.org/en/2.5/pages/installation/docker.html)

---

<div class="post-metadata">

**Author:** ![macko003](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/macko003/32/3175_2.png) [@macko003](https://community.graylog.org/u/macko003)\
**Post date:** [January 31, 2019, 12:48pm UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/10 "2019-01-31T12:48:19Z")

</div>

GL 2.4 won’t work with ES 6.x  
You need to update the GL’s config, not ES

> [@jan](#):
>
> did you notice the changes in 2.3 ( [http://docs.graylog.org/en/2.5/pages/upgrade/graylog-2.3.html](http://docs.graylog.org/en/2.5/pages/upgrade/graylog-2.3.html) ) the changed way Graylog connects to Elasticsearch.
> 
> Also the special note what you need todo after you upgrade graylog?

---

<div class="post-metadata">

**Author:** ![Bahman](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@Bahman](https://community.graylog.org/u/Bahman)\
**Post date:** [January 31, 2019, 3:21pm UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/11 "2019-01-31T15:21:07Z")

</div>

what i did was. i stop docker-compose, then i

docker run --name elasticsearch -e “http.host=0.0.0.0” -e “xpack.security.enabled=false”   
-d [docker.elastic.co/elasticsearch/elasticsearch-oss:6.5.4](http://docker.elastic.co/elasticsearch/elasticsearch-oss:6.5.4)  
then i  
get the gl:  
docker run --link mongo --link elasticsearch -p 9000:9000 -p 12201:12201 -p 514:514 -p 5555:5555   
-e GRAYLOG\_WEB\_ENDPOINT\_URI=“[http://127.0.0.1:9000/api](http://127.0.0.1:9000/api)” -d graylog/graylog:2.5  
Then i try to start docker-compose.  
i can see all steam and all alert and ,…  
But not search. i can’t search:  
error: cannot get http://…:9000/api/source?range=3600 (500)

---

<div class="post-metadata">

**Author:** ![macko003](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/macko003/32/3175_2.png) [@macko003](https://community.graylog.org/u/macko003)\
**Post date:** [January 31, 2019, 3:47pm UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/12 "2019-01-31T15:47:59Z")

</div>

Does elasticsearch run well?  
Do you see indices?  
What do you see in GL & ES logs?

//Before you copy these infromation please read and construe it.

---

<div class="post-metadata">

**Author:** ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)\
**Post date:** [January 31, 2019, 4:30pm UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/13 "2019-01-31T16:30:17Z")

</div>

> -e “xpack.security.enabled=false”

that is not needed when you run elasticsearch oss … no xpack is given and elasticsearch will not start with a setting it does not understand … so it looks like elasticsearch is not running IMHO

---

<div class="post-metadata">

**Author:** ![Bahman](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@Bahman](https://community.graylog.org/u/Bahman)\
**Post date:** [February 1, 2019, 10:33am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/14 "2019-02-01T10:33:08Z")

</div>

ok jan,  
it was in “quick start” from graylog instructionpage.  
I try to install elasticsearch with this command.  
docker run --name elasticsearch   
-e “http.host=0.0.0.0” -d [docker.elastic.co/elasticsearch/elasticsearch-oss:6.5.4](http://docker.elastic.co/elasticsearch/elasticsearch-oss:6.5.4)

---

<div class="post-metadata">

**Author:** ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)\
**Post date:** [February 1, 2019, 11:51am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/15 "2019-02-01T11:51:58Z")

</div>

fixed that … in the docs

So what is your current status?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex016/uploads/graylog/original/3X/c/7/c7c09c6b5099570133d6502b83f50ba4430de5b6.png) [@system](https://community.graylog.org/u/system)\
**Post date:** [February 15, 2019, 11:51am UTC](https://community.graylog.org/t/graylog-error-loading-field-information-failed-with-status-500/8591/16 "2019-02-15T11:51:59Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
